Jump to content

Focus 3 for Unity


Recommended Posts

Trying to figure out how to port a game made using the Unity XR Integration Toolkit and an Action-based XR Rig over to the Focus 3 in PC streaming mode.

Previously it was using the Oculus plugin.

I've gotten the Focus 3 headset to track but I cannot get the controllers to be recognized by Unity.

Current Setup is Business Streaming->SteamVR->Unity. I'm using the OpenXR plugin in the XR Integration Toolkit with SteamVR set as my runtime.

I've tried enabling the VIVE Controller Profile in the OpenXR settings and have also tried downloading the custom VIVE Cosmos Controller Support and enabling that.

I would like to avoid having to download the Wave SDK unless I know it won't require a complete redo of my the existing XR Rig and Input Action mappings.

My problem is not that the controllers aren't tracking correctly but that they're not recognized by Unity whatsoever.

I'm on Unity 2020.3.2f1 with XR Integration Toolkit 1.0.0-pre.5.

Link to comment
Share on other sites

I have now tried installing the 3 Wave SDK packages from the scoped registry and running the game with the WaveXR plugin checked in the XR Integration Toolkit however it crashes every time I click play.

I set the platform to Android from Windows Standalone and changed all the settings as suggested by the WaveXR dialog.

Link to comment
Share on other sites

Have you tried Vive Input Utility? It may be helpful for your case. 
One thing that if you aren't developing standalone content on Focus 3, you probably need Wave SDK to work. if you are aiming for PCVR content that streams through VBS to Focus 3, you will only need openVR.

Link to comment
Share on other sites

  • 4 weeks later...

Trying the same thing, VBS -> SteamVR + Unity. Seems to just hang up for a long time for me then Unity puts the player in non-vr WASD mode. But running it as build exe works. Seems to be giving "XR: OpenVR Error! OpenVR failed initialization with error code Unknown error (310): "Unknown error (310)"! "

This is kind of annoying since SteamVR is used widely and development with this workflow is important in enterprise.  Still testing the above suggestion as a work around.... Will report back. 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...