Jump to content
Happy Holidays! Limited Staff Responses: 1/20 - 1/31 ×

Cosmos Elite Display Not Showing But Still Tracking In Steam, Won't Boot


MrWhitty2000
 Share

Recommended Posts

I've had this headset for a year now and it's worked for the majority of the time - however, there have been many, many times where the console didn't load and I was able to play anyway, but it would often require a few boot-ups to make happen and the console would run as a "grey screen" and never really be there. I wanted to fix this, so I re-installed all vive software and NOW it literally will not detect the USB no matter what I do. I have an extended USB chipset (recommended one as well), along with many other ports on the pc itself. The crazy thing is - it is TRACKING in steamvr, but not showing display. It's always worked, even if it took a couple of initial attempts but this is just getting insane. I've been up for 12 hours - I have a sponsored ad to shoot for VR and I'm stuck doing this 😞 I've checked the cable and link box, both seem to be working just fine because I have 2 of each. Display port picks up right away but no usb. 

 

i7 8700k

1660 6GB

16GB RAM

I've even tried an adapter for my USB C port and still nothing.......and I just got full body tracking. Fml. PLEASE HELP. This is beyond insane at this point. The only thing I can possibly consider is the power supply....but then again, would it even track in steam if that were the case? Or register the display port? Ugh......

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...