Jump to content

Unity : Unable to enter Play Mode with headset.


dev_imag-ing
 Share

Recommended Posts

Hello,

 

I have a Focus 3, and I want to develop on it using Unity. The only issue now is that I cannot use the headset directly in Play Mode, and building everytime I want to test something is tedious.

I tried the Direct Preview, over Wifi and USB, and the connection always Timeout.

I tried using Vive Business Streaming over SteamVR as well but to no avail (using SteamVR as the OpenXR execution environment).

 

I use:

- Unity 2020.3.29f1 with OpenXR and WaveXR checked in the XR Management System. SteamVR being the Play Mode OpenXR Runtime.

- VIVE Wave XR Plugin - Essence 4.4.0-r.8

 

GPU: NVidia Quadro P5200 (in the nvidia control pannel, all of steam, vive and unity softwares are already set to use the GPU only)

CPU: Intel i9-8950HK

 

How can I do to dev and test pleasantly ?

 

Thanks and have a nice day, cheers.

  • Like 1
Link to comment
Share on other sites

Hi Mark, thank you for the answer.

 

WaveXR is enabled for PC as well, but it did not work, may it be over USB or WiFi.

After the server is started in Unity, I launch the APK from Unity, and in the headset I get a Connection Timeout after a few seconds.

 

When using VBS on PC platform, I can see the SteamVR environment with the Vive logo and "STREAMING" written under it.

But when I launch the Play Mode in Unity, my second camera shows in the editor and nothing happens in the headset.

I am using the XRRig from the XR Toolkit and the second camera is not tagged as "main".

  • Like 1
Link to comment
Share on other sites

Hello, I am having the same problem on HTC Focus 3

It doesn't work at all on wifi. Followed the procedures of the official documentation countless times, no error, everything works, the server is on, helmet is detected... But static image on the helmet...

After multiple hours of test, I managed to make it work with a very non-practicle hybrid method :

I set up the settings for the wifi, then switch to the usb panel and launch the stream app, then the apk. I have an image on the unity editor but not on the helmet (thanks usb), so it is not really usable.
It is very tiresome to build our apks again and again, could you please make a tutorial that goes from A to Z, one time, to have the directpreview working on wifi ?

It will save us so much time.

Thanks in advance.

  • Like 1
Link to comment
Share on other sites

  • 1 month later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...