Jump to content

[Tutorial] Focus3 OpenXR: Getting Started in Unity


Alex_HTC
 Share

Recommended Posts

So, looks like my problem is down to the beta not yet being approved for my device. I need to wait on that.

When will this leave beta and roll out for all device users? I manage a bunch of devices through the manager and most are in the hands of clients.

Link to comment
Share on other sites

Beta approved, and I cannot join it on the device, it says the device is not approved. I have the confirmation email and I have double checked I sent the correct device serial number.

Link to comment
Share on other sites

12 hours ago, tonkso said:

Still not having any luck. This device is managed via the device management system as part of our organisation, if that has any impact?

had similar issue but different cause. In troubleshooting, however, I was informed:

You cannot be enrolled in device management. Also,  cannot be using location based entertainment packages. No DMS no LBE.

Go to device information and copy paste your complete headset registration information. Then remove your device from DMS.

If that does not work, contact the beta support email and send them both your device serial and headset serial number. There are two serials.

Link to comment
Share on other sites

  • 2 weeks later...
  • 2 weeks later...
On 5/16/2022 at 11:20 PM, Goldenfish said:

So do I, I'm suffering the same issue as you countered, have you solved this problem?  How did you solve this problem?

@Goldenfishwhat version of the ROM are you running on the headset?

Does this happen with the CI build as well? I ask since it may help narrow down https://github.com/hardcoded2/XR-Interaction-Toolkit-Examples/suites/7115048129/artifacts/282074089 is one example. Does the same thing happen with that apk versus a local build? This would point to an environmental issue.

Thanks,
Alex

Link to comment
Share on other sites

On 6/27/2022 at 12:23 AM, martini said:

@Alex_HTC

Hi, are there any news concerning this weird Tracking Problem in Standalone Mode with OpenXR?

@martiniWhat version of the rom are you currently running? I would suggest running the latest openxr beta 5.3.999.514. I didn't see this when running the below in the latest stable release (5.0.999.514) either. Please try the linked build and let me know what rom version 🙂

Does this happen on local builds only or does this happen only on a CI build like on https://github.com/hardcoded2/XR-Interaction-Toolkit-Examples/suites/7115048129/artifacts/282074089 ?

What is "weird tracking problem" more specifically?

Keep in mind that the controls for this test experience are:
 

Default controls: 

Use the Trigger button to interact with UI.

Use the Thumbstick to move and turn.

Use the Grip button to grab objects. When holding an object with your left-hand Ray Interactor, you can use the Thumbstick to rotate and translate the object. 


Glad to help!

Thanks,
Alex

Link to comment
Share on other sites

On 6/1/2022 at 2:37 AM, tonkso said:

Is this compatible with the MRTK? I have an MRTK project that compiles and runs for Oculus Quest with no issue, but when I deploy to the Vive I get a blank screen and no input. The app does appear to be running as I get ADB output, but the app does not show in the app menu.

@tonksoI haven't tried it, but I suspect there is some settings that need to be tweaked so that IL2CPP does not strip out important classes.
Try a mono build first, as that avoids il2cpp method/class stripping that causes issues with reflection-based stripping.
If a mono build works, then start adding assemblies (and then classes) to link.xml as described here https://docs.unity3d.com/Manual/ManagedCodeStripping.html 

We're hoping to get a MRTK sample up at some point, and feedback like this helps us prioritize the work 🙂 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...