Jump to content

[Tutorial] Focus3 OpenXR: Getting Started in Unity


Recommended Posts

  • 2 months later...
  • 1 month later...

Like dev_imag-ing said above me, I just can NOT get this to work.  I have downloaded all the linked github sample projects, I can get the sample scene working with my headset affecting the camera, but no controllers, that's it.  When I add the "Interaction Mode Manager" in an attempt to get controllers working, this causes a crash on startup off the app in the headset.   The HTC tutorial page refers to things that just do not exist in the SDK, like an XR rig, I am so lost, for the love of God can someone please tell me how to get this working in Unity.

Link to comment
Share on other sites

Hi @Radicals,

Here is a link to getting OpenXR working on the Focus 3. This was created late last year, so it should be up to date right now.  https://developer.vive.com/resources/openxr/openxr-mobile/tutorials/unity/getting-started-openxr-mobile/


I also downloaded VIVE OpenXR Plugin - Android and VIVE OpenXR Toolkit Samples - Android. Inside the VIVE OpenXR Toolkit Samples, there is a sample scene called OpenXRInput. I was able to test out controllers with this scene. Does this not work for you?



Link to comment
Share on other sites

Thank you, I did eventually manage to get it to work, I tried everything and eventually it came good.  I am now struggling to get hand tracking working in Unity 2021.3.12, but it works in 2019.4.40, any advice?

(This is using the Wave-Essence package, and the demo scene "HandModelTest")

Link to comment
Share on other sites

To add: I am using the guide at:



But when I try their sample code, I get "not found" errors for:

using Wave.OpenXR.Toolkit; 
using Wave.OpenXR.Toolkit.Hand;

HandJoint joint = HandTracking.GetHandJointLocations(isLeft ? HandFlag.Left : HandFlag.Right)[jointNum];

(It can't find the hand toolkit nor the reference to "HandJoint", even though I followed all the steps and have the "VIVE Wave OpenXR Toolkit - Android" installed, v1.0.4

Edit: Wait, I had the "VIVE OpenXR Plugin - Android" installed, not the "VIVE OpenXR Toolkit - Android" installed....So confusing.  I will keep trying.

Edit: Still no luck, same issues even with the Toolkit installed.

Edit: Wait, restarting Unity fixed the above not found errors.  Continuing...

Edited by Radicals
Link to comment
Share on other sites

  • 4 weeks later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...