Jump to content
Happy Holidays! Limited Staff Responses: 1/20 - 1/31 ×

Direct Preview still not working


vethetheth
 Share

Recommended Posts

Hi @C.T. @chengnay, any news on directpreview ? It's been months and it is really, really becoming tedious to develop on your hardware.

Can we at least have an idea on where the problem is ? Everything works fine for you, but not a single developpers managed to make the directpreview work on this forum

Please help us. It can't continue like this.

Link to comment
Share on other sites

I would love to know how to make this work also!   It is incredibly slow and unproductive to build/deploy/test as that is a very slow process.  

For me the streaming server comes up, runs and is displaying valid log messages to the console window after I start up the device apk.  But, when I run inside unity the game does not show the headset (or controllers) moving.  I've tried via USB connection and wifi connection and neither works. 

If I look in the logs on the headset under /sdcard/DirectPreview I do see some errors messages popping up.  But I can't figure out what is causing those so am pretty much stuck!

image.thumb.png.27662bc7671dab21bfb621f5af6d5836.png 

Link to comment
Share on other sites

Hello, thanks for the answer. @chengnay already tried to help me through vbs but the hassle of duplicating every project / changing the platform each time i have to test results in a time loss bigger than building the apks directly to test.

Could you please have a look at direct preview ? It would mean a lot.
Thx.

Link to comment
Share on other sites

  • 4 weeks later...

Hi @vethetheth,

Sorry for the late reply.

Thanks for keeping feedbacks about the Direct Preview function.

In past periods we remotely worked with some developers to clarify their environments or setup steps, and indeed observed there were some missed points or steps may cause the failure case. 

So we try to record a video tutorial and rephrase our online document to make it more clearly, and we should share out quite soon.

Before that, we'd like to support your case via remote debugging.

Please PM me and we can setup if it's okay for you.

 

Link to comment
Share on other sites

  • 2 weeks later...

Hi @chengnay, @Vivi Wu, i have some news

The IP adress was not the right one, now i can test and i found out some things :

It is now working, but the hands are stuck on my feet, the controllers are working fine.

I am testing with the scene 0 from VIU, did you try hand tracking with direct preview ?

Also, sometimes the screen freezes and there is written 

Quote

WVR_DirectPreview: Pose origin is changing!

endlessly in the log files. But before it worked great.

Thanks in advance.

 

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...