Jump to content
Happy Holidays! Limited Staff Responses: 1/20 - 1/31 ×

[ PC VR / Windows ] VIVE OpenXR Tutorials and Plugin (Update for Fota5.3)


Vivi Wu
 Share

Recommended Posts

For PC VR content, we provide more plugin and tutorials for OpenXR PC VR on VIVE official developers website.

Now, for Focus 3, user can connect PC VR content by using VIVE Business Streaming .

 

Supported Devices: Vive Cosmos series, VIVE Pro series, VIVE Focus 3+VBS

Tutorials:

  1. Unity:
  2. Unreal Engine:
  3. Focus3 + VBS:

Supported engines: Unity and Unreal Engine (Plugin Download)
※ Vive Focus3 for facial tracking, please update your Focus 3 version : 5.0.999.646 or later.

Unity

Feature Name Cosmos VIVE Pro Series VIVE Pro Eye VIVE Focus3 + VBS
Hand Tracking
Scene Understanding  
VIVE Cosmos controller    
Facial Tracking    

VIVE Focus 3 controller      

Unreal Engine

Feature Name

Cosmos

VIVE Pro Series

VIVE Pro Eye

VIVE Focus3 + VBS

Hand Tracking

Scene Understanding

 

VIVE Cosmos controller

 

 

Facial Tracking

 

 

Game Engine OpenXR Support

VIVE OpenXR Plugin Support

 

※ If you want to develop the mobile content of Focus 3, please visit OpenXR for mobile.

  • Like 1
Link to comment
Share on other sites

  • 4 weeks later...

@Vivi Wu

I have removed the ViveSR SDK completely and installed from VIVE Wave OpenXR Plugin - Windows from package manager and imported facial tracking example.

When I ran the example, nothing moved at all (by the way, the way the example setup is really not intuitive), so it didn't run out of the box.

I tried adding Eye_Framework script and checking 'Enable Eye', but I got this null exception.

[url=https://ibb.co/6ZCJ0Pn][img]https://i.ibb.co/RSw4T0v/image.png[/img][/url]

I have tried uninstalling and reinstalling the whole vive software and made sure that SRanipal is running and I tried VCC which ran fine and the eye tracking worked on it, so SRanipal and the service seem to be working correclty.

Link to comment
Share on other sites

@Vivi Wu

 

When I changed Play Mode OpenXR Runtime to SteamVR it worked, but this would only work in editor not in build. The build still doesn't work.

hXf2k8MslavJ.png?o=1

Here're the settings I have in XR Plug-in Management and the image above shows the settings of OpenXR

FrQmbxFqSCfb.png?o=1

 

If I leave "Play Mode OpenXR Runtime" to "System Default", it doesn't work and below is the console log.

spacer.png

How to make it work without forcibly changing "Play Mode OpenXR Runtime" to "SteamVR"?

How to make it work with the build?

Link to comment
Share on other sites

Hi @Vivi Wu

Thank you, I appreciate this update. It would help save time as most developers would have multiple headsets with multiple runtimes.

OpenXR unity package has a sample with Controller.scene in it. It has EyeGaze setup like this, but it doesn't seem to track with vive pro eye.

Is this not supported yet, or am I doing something wrong?

image.png

Link to comment
Share on other sites

Hi @StrangerGames,

After few tests, we suspect this problem might be Unity’s issue, since it’s all working fine on UE4 OpenXR eye gaze.

We’ve reported this to Unity, and our suggestion is you can also go to Unity community to raise up.

And if there’s any new feedbacks, we'll let you know.

Thanks.

  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...