Jump to content
Happy Holidays! Limited Staff Responses: 1/20 - 1/31 ×

Error CVRSystem does not contain a definition for 'IsInputFocusCapturedByAnotherProcess'


jboss
 Share

Recommended Posts

Hi,

I am getting this compile error in my project. I tried to install the latest version of the package from the assetstore, but that did not solve the issue.

Assets\HTC.UnityPlugin\VRModule\Modules\SteamVRModule.cs(583,32): error CS1061: 'CVRSystem' does not contain a definition for 'IsInputFocusCapturedByAnotherProcess' and no accessible extension method 'IsInputFocusCapturedByAnotherProcess' accepting a first argument of type 'CVRSystem' could be found (are you missing a using directive or an assembly reference?)

Please let me know how to fix this.

Thanks!

Link to comment
Share on other sites

Yes, it's PC VR for the Vive.

SteamVR 1.2.3

VIU 1.17.0 (I think.... it does not show up as package in the project, only in My Assets, and when I click import it keeps telling me the binding_ui_icons.png is changed)

NewtonVR, but I can't find a version of this.

And a bunch of others for SQL, Licensing, cones or multilingual support, but I don't expect them to be relevant fro this error.

I tried adding the scripting symbol VIU_STEAMVR_1_2_3_OR_NEWER, to the player settings, so that it would not even get to the error line, but when I reopened the project it was gone again.

Oh, and it's Unity 2019.4.39f1

Link to comment
Share on other sites

Hi @jboss,

Are you able to upgrade your project to latest SteamVR Unity Plugin?

It seems like using VIU v1.17.0 with SteamVR 1.2.3 has unexpected errors.

From my side, I didn't see compile error, but lots of "Cannot set VR devices because the platform passed isn't supported by Unity." and obsolete warnings.

Link to comment
Share on other sites

Hi @chengnay,

Unfortunately upgrading the SteamVR plugin breaks the NewtonVR package that I use for real-time collision detection. And I haven't found a good alternative for it.

It would be great to be able to use the VIU StickyGrabbable component, but then I would need a solution for questions/feature requests I posted earlier 🙂

 

After a night's sleep I realised my other big project is also using VIU with SteamVR 1.2.3 and there I don't get the error. I'll see if copying the VIU folder and SteamVR foledr solves it in this project.

 

Link to comment
Share on other sites

This thing is starting to freak me out

Tried copying the two folders, no effect.

Found an OpenVR folder in /Assets/Plugins and copied that, no effect.

Decided to bite the bullet and upgrade to SteamVR 2.7.3 and VIU 1.17.0 and as expected got a bunch of compile errors, not only in NewtonVR, but also in my own scripts and, surprisingly, in VIU scripts. Something with ExternalCameraHook.

Finally decided to simply comment out the line with the error and replace it with 'return false' and then Unity crashed and now the project will not start again. The same thing actually happened when I added the VIU_STEAMVR... scripting symbol. Unity crashed and the change was not made.

So there's something really weird with this project, and probably not related to VIU at all.... I'll keep on digging.

 

Edit after posting: I noticed that my earlier reply from today is marked as hidden, so I don't know if you're able to see it. This one seems to be posted right away.

Edited by jboss
Link to comment
Share on other sites

Well, Unity blows my mind again.

It was the scripting symbols. The last one related to SteamVR and VIU in the project was VIU_STEAMVR_1_2_1_OR_NEWER. The error was related to VIU_STEAMVR_1_2_3_OR_NEWER, but as I mentioned when I added that the editor crashed and after reopening the new symbol was gone.

I tried adding both VIU_STEAMVR_1_2_2_OR_NEWER and VIU_STEAMVR_1_2_3_OR_NEWER and then it worked. Nothing in the script or anywhere suggested that I would have to add this 1_2_2 version, but apparently I had to.

Sorry I wasted your time to investigate, but it helped me get my thoughts straight 🙂

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...