Jump to content
Happy Holidays! Limited Staff Responses: 1/20 - 1/31 ×

DirectPreview is notwork... connection is timeout


Cupeamer
 Share

Recommended Posts

hi..i'm using focus3 to test some scene. Unity version is 2020.3.41 . wave sdk version is 5.0.3-r5.

when i use wifi to directpreview, no image in my hmd,only show the message tip ."Conneciton is time out".

then i change to use usb , alway show the same tip.

but in the two model. i can do every thing by controller, just no image. what's wrong in my PC  or any config?

Link to comment
Share on other sites

@Cupeamer
Try going through the instructions again on https://hub.vive.com/storage/docs/en-us/UnityXR/UnityXRDirectPreview.html 

First thing i found out was to make sure the headset is connected by usb and after changing the wifi address or any other configuration, make sure to "push apk" which also uploads the new configuration. 

Let's make sure that the headset is reachable from the pc that is streaming.

1) Find the IP of the headset, for example might be
     a) 192.168.11.5 - likely on the same network
     b) or something along the lines of 10.0.0.100 or 172.16.0.100 -- if they look this different, the headset may be connected to a different network
2)  Even when connected to the same network, sometimes the network prevents devices from talking to one another.
       So lets make sure that the headset is reachable from the pc by finding the ip of the headset, for this example let's use "192.168.11.5"
     a)Open cmd
 
cmd_open.png.f6e24692475b4686378c4e2420c4063b.png
  b)run ping command against the ip address of the headset (in this example I assume the headset is at "192.168.11.5")

ping_headset_ip.png.e6db79e403232277254d16729d75c088.png
If it looks like this, then the two devices cannot talk to one another
c) consult the network administrator or network admin panel if you own this network (for me, it's at http://192.168.0.1/ ) and consult documents to make sure that there are no firewall rules preventing udp traffic
d) make sure that if your pc that is streaming is on multiple networks, to set the device ip using the dialog shown in your post. otherwise it shouldn't be necessary. this happens if the pc has a wireless adapter and a wired adapter both connected, for instance. 

For my own personal example:
This is something I have to consult occasionally as I have a few home networks. If I find my headset's current ip, i go to settings->general->about and then headset status, and that popup will show the ip address
Open Settings
1settings_general_about.thumb.png.b4dcf53c27d24b6bd81627b4791c40bd.png

Open About headset 
2settings_general_about_headset_status.thumb.png.fbfbaf2478d77ea229a633b512c1e21f.png

In the above picture, I notice that my ip address is "192.168.4.43" which I happen to know is on a different network than my pc. 
I can verify this as it's not reachable when I try to ping it
ping_real_failure.png.2f2908fa519218677bb9e799c86943b9.png

I then go into my network settings and change my connection to my other network
Then verify that I'm on the same network by going back through general->about->headset status again
4_ipaddress_correct_network.thumb.png.cdf6b764f03fc71826e7502d1cbdb4fe.png

Here I notice my headset's ip address "192.168.0.170" is now reachable from my pc
ping_real_success.png.95c983d2fa17b1e22ecd5cb7e9293b60.png

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...