Jump to content

Updating firmware: volume down not entering download mode


Recommended Posts

I have a Flow that was previously paired to an Android phone I no longer have.

Saw the January update added iPhone support.

Trying the instructions here: https://www.vive.com/us/support/flow/category_howto/how-to-update-vive-flow-to-support-iphone.html

However, holding Volume Down button and plugging device into USB-C cable connected to macOS laptop never enters download mode as described in that page.

Instead, it just shows the screen saying to install the Android app.

I've tried resetting to factory settings but no change.

The Vive app on iPhone detects the Flow but cannot connect to it.

Thanks for any help!

Link to comment
Share on other sites

Hm, ok if I hold down power AND volume down I can get into a mode which has the following:

* system info

* show barcode

* reboot to bootloader

* reboot to download mode

* reboot

* power down


`adb devices` still doesn't list anything though, so the flash script fails.

This must be download mode, since choosing "reboot to download mode" comes back to this screen.


Choose "reboot to bootloader" gets me to bootloader screen, which has more choices, like "reboot to recovery".

`adb devices` in bootload mode still doesn't list anything, so the flash script fails.


Going into recovery mode, more interesting choices:

* Apply update from ADB

* Apply update from SD card

* Wipe data/factory reset

* Wipe cache partition

* Run graphics test

* Run locale test


Choosing "Apply update from ADB" sounded promising, so chose that, and sure enough the devices shows up in adb device list now, but with the word "sideload" next to it, and no other adb commands work.


Feels closer anyway. I wonder if maybe there's a way to sideload the update ROM?

At the least, the support document should be updated to say to hold down power and volume down, not just volume down.

Link to comment
Share on other sites

@crispy71 I tried again yesterday, and I was able to complete the device update.

A red herring was that I was attempting to determine device connectedness using adb, but that doesn't work w/ devices in fastboot mode.

Enter download mode via the following steps:

* unplug Flow

* hold down power and volume down

* plug in flow, without letting go of the buttons

It then entered the first state described in my second comment above.

I was able to update the device using the firmware and flashing process linked in my initial comment above.

Note - I had to run the flash script and force-kill it (ctlr/cmd+C) a couple of times before it got far enough along. Seems to hang on the battery check command on my device. Maybe doesn't happen for everyone.

In fact, IIRC I opened up the script and run some of the commands manually without the battery check line. Sorry, don't remember exactly.



Link to comment
Share on other sites

  • 2 months later...

I've been having issues with updating the firmware too and so far support has proved to be useless. I think there's something wrong with the installer?

I run Ventura 13.0.1 and have been trying for days with the same results. This is what happens in Terminal when I try to update? I feel like either I'm doing one little thing very wrong or there's something wrong with the file itself. 

VIVEFLOW_Mac\ \(1\)/VIVEFlow.sh

Enter Download Mode

 VIVEFLOW_Mac (1)/VIVEFlow.sh: line 7: ./adb: No such file or directory

set battery level check

VIVEFLOW_Mac (1)/VIVEFlow.sh: line 10: ./htc_fastboot: No such file or directory

Enter RUU

VIVEFLOW_Mac (1)/VIVEFlow.sh: line 12: ./htc_fastboot: No such file or directory

Flash Partial Finished

set battery level check

VIVEFLOW_Mac (1)/VIVEFlow.sh: line 15: ./htc_fastboot: No such file or directory

Flash Signed

VIVEFLOW_Mac (1)/VIVEFlow.sh: line 17: ./htc_fastboot: No such file or directory

Updated VIVEFlow FW Finished.

VIVEFLOW_Mac (1)/VIVEFlow.sh: line 19: ./htc_fastboot: No such file or directory

Reboot VIVE Flow and enjoy your journal.

VIVEFLOW_Mac (1)/VIVEFlow.sh: line 21: pause: command not found

Please Press Any Keys To Close WIndows.

Link to comment
Share on other sites

  • 3 months later...
  • 1 month later...

It seems that you're having trouble entering download mode on your Vive Flow headset while trying to update it for iPhone support. Despite following the instructions provided, the device continues to display the Android installation screen. Resetting to factory settings hasn't resolved the issue, and the iPhone's Vive app cannot connect to the Flow. You may need to reach out to HTC Vive's customer support for further assistance in resolving this problem.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...