Jump to content

Is there anyway to play The Elder Scrolls V: Skyrim VR with XR Elite controllers?


Recommended Posts

I can't play The Elder Scrolls V: Skyrim VR because the game doesn't seem to support XR Elite controllers by default. At the very beginning of the game we are forced to select either left-handed or right-handed with a touchpad, but we can't select it because XR Elite controllers don't have touchpad. I'm stuck.

I'm hoping there may be a work-around for this problem by setting up appropriate controller bindings, but I have no clue. Any help would be really appreciated.

Link to comment
Share on other sites

I initially had the exact same problem when I tried to play this using the native Vive streaming app. However, I recently tried again using Virtual Desktop and everything seemed to just work fine in Skyrim VR. I don't remember changing any settings or having to mess with the controller mappings, it just worked. I am not sure what else would have been different besides using Virtual Desktop to stream it instead of the Vive app.

  • Thanks 2
Link to comment
Share on other sites

Posted (edited)

SuperGrover, thank you again for your information. The XR Elite controllers do work without any additional settings when I play the game via virtual desktop app.

Virtual Desktop (viveport.com)

It was definately worth $20. Best Regards.

Edited by dabu
  • Like 1
Link to comment
Share on other sites

  • 4 weeks later...

I sometimes use the Quest 2 Virtual Desktop, rather than Air Link because it provides a better game menu for both Steam and Oculus PC games. However, when using the XR Elite, how do you play SkyrimVR using the Steam Virtual Desktop? A step-by-step response would be appreciated.

Edited by Calcanuck
Grammar error.
Link to comment
Share on other sites

Calcanuck, I am using Virtual Desktop that is natively installed on the XR Elite, not the Steam version of Virtual Desktop. When using Virtual Desktop on the XR I imagine it would be similar to how you are using the it on your Quest 2. I literally just run Virtual Desktop from the XR and launch Skyrim VR from the Virtual Desktop menu and it just works.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...