Jump to content

Bluetooth Link communication failed


Recommended Posts

  • Replies 28
  • Created
  • Last Reply

Top Posters In This Topic

  • 3 weeks later...

I am having the exact same issue as ShadowMars. I tried uninstalling the USB drivers, switching to a different USB port (2.0. 3.0, 3.1—I should note I am using the Vive Pro Kit), and uninstalling other Bluetooth devices (USB dongle), but none of these solved the problem. Trying to Enable Bluetooth Communication only makes the app display the error message every time (Bluetooth Service Error: BT-112).


I noticed that this feature broke only recently, and I'm guessing it might be related to SteamVR update. I'd be looking forward to some insight from anyone more knowledgeable on the subject.

Link to comment
Share on other sites

  • 1 month later...

I removed and reinstalled all Vive drivers using USBDeview (currently included in SteamVR tools), that didn't solve the problem. Is there a method to perform, say, a clean uninstall of these drivers?

Link to comment
Share on other sites

The Bluetooth power management feature is, most importantly, capable of extending the life of base stations, by turning them off when they are not in use and thus decreasing wear to their moving mechnical parts. I'd rather have it working properly.


From what I could find out, there might be a bug in the Bluetooth driver itself, as it threw an error indicative of that when I tried to reinstall it manually.

Link to comment
Share on other sites

  • 4 weeks later...
  • 2 weeks later...

This worked for me today, 2 years after this was posted. I think it's great that this workaround is available, but I also think it's a bit of a copout to blame the USB drivers, which are all Vive's drivers. A $1400 kit should not require this level of handholding just to keep it updated. If uninstalling and reinstalling all drivers is the solution, then the SteamVR app should do that on its own without requiring users to have to google for a solution and then do this themselves via a Developer setting.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...