Jump to content

Streamed AR for Unity - VIVE XR Elite


Virtus

Recommended Posts

16 hours ago, Virtus said:

It seems like when I activate both scene planes and scene meshes, the scene planes takes the priority on the display, resulting in no scene mesh displayed.

I don't quite get your statement, could you provide some screenshots and explain more?

Are you using SDK's sample scenes for this case?

Link to comment
Share on other sites

Hello,

Yes I am using the demo scene sample. I activated the possibility to display at the same time scene meshes and scene planes.
But when I am testing, only the scene planes are displayed
 

mesh+planes.png

nomesh.png

Link to comment
Share on other sites

Hi @Virtus,

I have tested ScenePerceptionDemo(SceneMeshAnchor) demo scene, it should be working correctly.

Please make sure you did setup Settings>Boundary>Mixed reality once before opening your application.

And you must scan your room and create at least a plane(Window/Wall/Door/Desk) and 3D Object(Sofa/Miscellaneous).

image.png.0436f921fb387af57571c667b1e09e3e.png
 

As you can see from below image is where I have scene mesh with plane anchor(yellow box) + 3D Object anchor(red box).

image.thumb.png.a26ebaf0b5101617c5047f2aa3e8e258.png

Scene mesh can be switched ON/OFF by RIGHT controller's B button.

Link to comment
Share on other sites

Posted (edited)

Hello,

my issue seems different. I successfully setup the MR scan of the room with planes.
My issue is I can have mesh and planes, but not both at the same time displayed like in your example.

You can see in the screenshot I gave you that in the debug panel, it is displayed "Scene2D Plane, 3D Objects Mesh + Spacial Anchors". It is supposed to mean that mesh is supposed to be displayed there no ?

best regards

Edited by Virtus
Link to comment
Share on other sites

7 minutes ago, Virtus said:

my issue seems different. I successfully setup the MR scan of the room with planes

For 3D Objects, you need to setup Sofa/Miscellaneous in Settings>Boundary>Mixed reality.

I already tested the sample scene which should work fine.

I did the same by checking 2D plane, 3D object and scene mesh.

Please go back to Settings>Boundary>Mixed reality and check again, thanks!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...