Jump to content

Unity 3D Colliders bug after Steam latest update


Recommended Posts

I'm developing in unity 3D (2021.3.15f1) with HTC Vive Pro, suddenlly after the last update of Steam VR (2.5.5 - I have already contacted them and they pointed at this direction) At first when I entered Play mode the hands started jumping around, similar as when a base station is Off. If I press the Menu of the controllers On and Off they stop jumping but the collider detection of the hands won't work anymore... everyting is up to date. After the "shaking" hands if I press the Menu button they stop, but cease to collide. I noticed that changing the mask collider of the hands to "nothing" stopped the jitter but obviously all the colliders got messed up, my project depends on those...I'm also sending a video with unexpected behaviour of the colliders; the video shows  that the controller is not in the right spot when the teleporting image tutorial is up, then if the hand gets close to any collider it moves erratically but only until an interactible object is grabbed, then after grabbing any  it looses its colliders (apparently). I know this because a have another object that triggers sounds when the hand collides with it and this one only works if I have not grabbed any other object from the scene. Any advice will be appreciated thank you.

 

 

Link to comment
Share on other sites

Hi @VIVE_chengnay,

Thank you for your reply, my firts move was to contact Staem VR support and after many messages this is what I got:

"Thanks for the additional context about the issue.

Please note that there's no option to go back to the previous version.

Also to continue, we'll be needing a SteamVR System Report. Start by making sure that your VR devices are connected to the host computer and their power sources. If possible, make sure your controllers are powered on and paired..."

------------------------------------

" Sorry you're having issues with your hardware.

It seems like you're using non Index VR devices that we can only provide limited support.

We recommend you to contact HTC support with the following link. They can best assist you in this case:..."

 

I restarted Steam VR many times, I even got it reinstalled and nothing. Thanks again.

Link to comment
Share on other sites

14 hours ago, VIVE_chengnay said:

Hi @Kb2,

Could you try creating a sample project and see if the issue still exists?

If yes, could you share the sample project for further investigation?

Thanks!

Hi @VIVE_chengnay,

I just did and it is not happening over the new project...something changed in mine after the update, I tried to delete and re import the Player prefab but did not work, I notice straight away that something is wrong when entering playmode and the teleprting tutorial controller is out of place, there is an image link below, thanks.

https://drive.google.com/file/d/11ytpvXm9z64w41gXr2wL197OxLZcWifF/view?usp=sharing 

Carlos

 

Link to comment
Share on other sites

Hi @Kb2,

If new project cannot reproduce the issue, then I suspect there must be something wrong with your project.

Could you try create new empty scene with only Player prefab in your project?

If issue still exists, please close your Unity and delete Library folder and launch Unity and let it regenerates.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...