Jump to content
Happy Holidays! Limited Staff Responses: 1/20 - 1/31 ×

Viveport applications work, SteamVR ones don't


Matti

Recommended Posts

I have lately bought HTC Vive and new computer for it. I have problems running appliactions under SteamVR. SteamVR Home works without problems. SteamVR menu system likewise. Vive software works. Everest VR (start it under Vive program) works. SteamVR Tutorial and The Lab don't work. I removed both and reinstalled SteamVR.

When I run SteamVR Tutorial, loading window(?) appears in the visor where 3 bars change shape. Then appears SteamVR user interface, where I tried to run the application (SteamVR Tutorial). When I try to run application again, appears an error message (translated from Finnish):
Starting shortcut...
Starting game SteamVR Tutorial failed.

Based on the previous experiences, I feel that running any VR applications from Steam-library would behave like this. Help!

Link to comment
Share on other sites

 

That's interesting. So Steam based games don't work for you? Is it all games, or just VR games?
Did you contact Valve's support? If so, what did they say about the errors?

I wouldn't blame SteamVR (since that application works) but it sounds like those two applications (SteamVR tutorial and The Lab) are having issues. I would test more Steam applications to see if the problem repeats itself or if it's limited to those two.

Thanks,

-John C

Link to comment
Share on other sites

VR applications I have tried so far:

SteamVR, interface, Home, all work

Everest VR under Vive application library works

SteamVR Tutorial; detailed in the first post

The Lab; largely same as Tutorial with following differences: game window appears in the monitor (as does Everest VR) but only functional item is level menu which opens with a mouse, and mouse cursor highlights the levels (otherwise window is black). In Vive headset is SteamVR user interface, message the application is running and a button to shut it off. When I turn interface off (controller button under trackpad), I see mostly white space with some black (or gray) circles and lines marking the floor.

 

My brother got our parents' house and Vive & rest are over there in a sizable room. I left some downloads on from Viveport (Tiltbrush and 1 other) before I left and I'll try those tomorrow. I'll install some more games from Steam tomorrow, maybe Worms Armageddon and Broforce. I haven't got answer from Steam support yet.

Link to comment
Share on other sites

Some computer information:

Core i7-7700

GeForce GTX 1080 Ti; last driver download made in last friday with GeForce Experience

Windows 10 Home in Finnish language

Computer was assembled week ago, pre-installed software including Win10 and drivers, no bloatware I could see, and they didn't even install free antivirus software as I had requested. It has AVG Free now and it didn't find any threats.

Link to comment
Share on other sites

I got answer from SteamVR support. This was the problem and solution:

SteamVR can have difficulty gaining proper access to Windows Device resources if your Windows User Account has any special characters or spaces in it.


Simply renaming your Windows User Account does not change the directory structure completely. A new Windows User Account must be created without any accent, foreign characters or spaces. This should clear any conflicts that prevent SteamVR from establishing communication with your Vive equipment during the Room Setup process.

 

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...