Jump to content
Happy Holidays! Limited Staff Responses: 1/20 - 1/31 ×

USB driver's won't install


xKristin

Recommended Posts

I got the error message 108 so I installed the program USBdeview and uninstalled all the USB's except for my keyboard and mouse. I restarted my comp and plugged everything back in. The drivers didn't install. Nothing happens. The USB's for my htc vive don't work anymore. How do I fix this?

Link to comment
Share on other sites

Hi 

 

Where are you based out of?

 

It looks like you've tried a few things but I'm a little concerned that nothing is being detected on the PC. 

Can you describe your set up a little more (PC make/model motherboard + graphics card + OS)?

 

Make sure that the linkbox power adaptor is plugged in both to a power source and to the linkbox. Plug the USB to the link box via (preferably) 2.0 USB port and the HDMI cable from your graphics card (not any built in motherboard HDMI) to the link box.

 

When plugging in the 3-1 cable to the linkbox plug the power plug first, then the HDMI and USB, verify if the drivers install, if you get an error 108 still, let me know if your headset light at least turns on, even if it is red.

 

Thanks!

 

JohnG

Link to comment
Share on other sites

I see that you also posted here: https://community.viveport.com/t5/Technical-Support/Error-108-nothing-works/m-p/13565#M4485

 

For continuity's sake let's keep it to this current thread.

 

Here is the info you posted on the other thread:

 

"I just got the HTC vive for christmas and got the error 108. Here's a list of things that I have tried:

 

- Went to device manager and disabled "allow the computer to blah blah" for generic USB hub.

- Tried to reconnect all the usbs a thosand times.

Tried every USB port (2.0 and 3.0)

- Tried to restart my PC multiple times

- Tried to plug all the orange cables directly to my PC instead of using the Link box.

- Downloaded the program USBDeview and uninstalled all the usbs except for mouse and keyboard and then connected everything again. This resulted in that when I try to connect a USB now, nothing happens. The drivers won't install. Tried to restart my PC, still won't work.

 

At this point I'm so lost. I don't know how to fix this and I've been trying for hours. My PC specs:

i7 4790k cpu

gtx 1060

Z97S SLI Krait edition motherboard"

 

Link to comment
Share on other sites

Based on your hardware info, can you please make sure the Vive is plugged in per my previous instructions, launch USBDeview and take a screenshot (ok to post multiple) so that I can see all of the components.  Make sure to sort everything by vendor ID and get as much of the information visitble (i.e. fullscreen) as you can.

 

Thank you,

 

JohnG

 

Link to comment
Share on other sites

Thank you for the reply.

By "where are you based out of" do you mean my country? If so, I live in Norway.

My linkbox power adapter is plugged in both to a power source and
to the linkbox and the USB to the link box is plugged in via a
2.0 USB port. The HDMI cable is plugged into the GPU and not the
motherboard.

I have tried plugging in the power plug first and then the HDMI and
USB. The driver's still won't install. 

Here is a screenshot of how everything looks like when all my vive cables are plugged in. When I first installed USBdeview everything showed and there was a red light on my vr headset and the controllers had a green light on them. Now there's nothing and the USB drivers wont run when I plug the cables in (even after restarting my computer) and they don't show up on USBDeview. 

Link to comment
Share on other sites

Thanks for the screenshot.

 

Do you have a thumbdrive? If so, let's test the following:

 

1. Keep the linkbox plugged in to power.  Unplug the 3-1 cable from the linkbox. Keep the USB cable connected from the PC  to the linkbox. Plug a thumbdrive into the linkbox and see if windows detects the thumb drive.

 

If it does then we can safely say the linkbox is communicating with the PC (move to step 2). If it doesn't, plug the thumbdrive directly to the USB port that you had the linkbox usb cable plugged into and see if it detects then (if it detects the thumbdrive directly then we may have a faulty linkbox).

 

2. Make sure the 3-1 cable on the headset is well seated across all connectors:

 

Completely shut down Steam and SteamVR

Open the cap on the top of the HMD by pushing it forward with both hands.

    1. Remove gently each cable and plug them back in tightly.
      • Make sure the 3-in-1 USB cable is connected in the USB port of the middle whenver possible.
    Align the ridge on the cover with the tabs on the compartment, and then push the cover until it snaps in place. Push the top cap back into the HMD, fitting it properly into place.

3. Plug the 3-1 cable to the linkbox again making sure it is properly inserted into each respective port.

Relaunch SteamVR

 

Let me know your results.  We are light on monitoring in forums these next few days during the holidays.  I will be checking in but my follow up responses from this post will be delayed. I will follow up again to any response you provide tomorrow.  My apologies in advance for the delays.

 

Regards,

JohnG

 

 

 

 

 

 

 

Link to comment
Share on other sites

I did step one and windows did not detect the thumb drive. I then tried directly plugging the thumbdrive to the USB port and it was detected. However, I don't think that there could be something wrong with the linkbox as everything was working fine before I used the program USBDeview. I installed USBDeview and uninstalled everything except for my mouse and keyboard. I then restarted my computer and plugged all the cables back in and then nothing worked anymore. 

I tried doing the same thing with my thumbdrive just now. Plugged it in, clicked "uninstall selected devices" in USBDeview, plugged it out and then back in and it still works. So why did this happen with all my cables for my htc vive? I just don't get why everything worked perfectly fine before I used USBDeview and now none of it works. Clicking "uninstall selected devices" in USBDeview shouldn't have completely broke the Linkbox and all the cables. So the issue must be something else.

Link to comment
Share on other sites

There is nothing I can think of from USBDeview that would have caused this.  The computer should respond to plugging in with the drivers uninstalled.

 

Have you considered uninstalling steamvr and redownloading/reinstalling? Not the entire Steam client but just SteamVR.  Might be worth an attempt to see if it forces the drivers to be recognized again.

 

Does anything show up in Device Manager as an unknown device or some such when you plug in the Vive/linkbox etc?

 

Thanks, apologies for not having a solution for you on the first try.

 

 

Link to comment
Share on other sites

I tried uninstalling steamvr and reinstalling, it did not fix the problem. 

 

Earlier I attempted to restore windows to a previous point, that point being 24th of december, 8pm. That is before I installed USBDeview and this whole thing started. When my computer turned on it said that the restore failed. However, when I opened USBDeview a few things had changed. I don't know what all of these devices are but before the restore the only things there was my mouse, keyboard and internet USB.

 

picture of all the USB's in device manager as well. Don't know what all of these are unfortunately. All I know is that nothing new shows up in either device manager or USBDeview when I plug in or plug out the cables for my HTC Vive.

 

EDIT: I just tried to plug in the HDMI and USB of the vive into my laptop. It did not work. I tried doing it with any without the Linkbox and nothing worked. At this point I think I will just deliver my headset to an electronics store and let them take a look at it and see what cables needs to be replaced.

Thank you so much for the help though! :)

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...