Jump to content

Vive Pro Not Recognized by SteamVR, Cameras Do Not Work


Recommended Posts

I have the same problem, same system, 5960X with an Asus X99-A


I went through a hell to make my Vive Pro working, but it´s finally working (also the hardware was not the problem because I tested it in a different PC)


But the cameras are not working at all, no matter in what USB I connect it, 3 or 2, no matter, cameras are not working, I enabled everything in privacy for the cameras, and tried the things said here, I even reinstalled Steam completely, nothing seems to be working.


I also have Windows 10 Pro 64Bit 1803


Please, help.

Link to comment
Share on other sites

  • 2 months later...
  • Replies 25
  • Created
  • Last Reply

Top Posters In This Topic

Hi Uri, perfect, thank you very much. I had same problems like you (no cameras working, only bluetooth checked in USB list, also can not change rate of camera and I can not also update firmware of HMD). I can play, have sound and after a few unplugs and restart USB devices also microphone).

I try all USB3 ports. Nothing.

Now I tried beta vr and USB2 and cameras start to go imnediately. And finaly I update firmare of HMD also on this port.

Super job. Thx.

And HTC team you should test more. Total. OMG. From start to end of instalation I know 1 thing for 100%, that I have to use only USB3 or higher. And finaly USB2 solves everything (I used the front panel) :O(((.

However when I plug linkbox back into USB3 - cameras are not working again :((. And I am still not able to change cameras rate. After steamVR restart again and again on same level :O((.

p.s. the white dot at USB list is only at bluetooth. This never changed.

Link to comment
Share on other sites

  • 1 month later...

Same issue here.


HTC Vive Pro with wireless adpater. Only BT in SteamVr USB tab and no camera working. 3 little red "x" testing camera. Before everything worked fine... one day it stopped to work. Needless to say i tried everything: uninstall all, reinstall all, switch back to cabled then swith again to wireless adapter,  USB 2, USB 3, USB C with adaptor, no USB HUB, with USB HUB, SteamVr beta, windows update, bla bla bla.


For a so expensvie device HTC should garantee better stability. Bad support, bad testing, bad documentation.


I came from the first HTC Vive and I hoped for a better experience considering the time spent between the two generations. Never more a HTC product. Bye HTC, welcome Pimax.

Link to comment
Share on other sites

  • 2 months later...
  • 1 month later...

Same for me. USB 2 is the only thing that works.  Even bought a PCIe USB 3.0 card and usb 3.0 hub thinking maybe it needed more power. Nope. Plain old USB 2.0.


HTC, care to comment? Is it Vive Pro or Steam VR issue? Hello?

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...