Jump to content

How I Installed Vive Pro Set and Got Rid of All Errors (Error 400, Compositor Not Available, etc.)


Recommended Posts

Hello everyone:


I've just finished setting up my Vive Pro complete kit (including 2.0 base stations and controllers), and in the process, I had absolutley every error people have raised here:  headset stopped tracking,  base stations & controllers intermittantly unavailable, the dreaded "Error 400:  Compositor Not Available / Not Full Screen," etc.  I'm happy to report that I figured out how to solve these issues and, more importantly, why some of us are having these issues and others of us aren't.  It all comes down to this:


If you have EVER owned any flavor of "Vive" before and are now upgrading your entire setup (not just your HMD), you will encounter these errors unless you do a COMPLETE uninstall of EVERYTHING related to the Vive and *start over.*  Here's how I fixed all of these issues:


1) Using Control Panel:

  a.  Uninstall ALL Vive Drivers and other similar files.  Basically, if it has to do with Vive, uninstall it.

  b.  Uninstall Steam VR

  c.  If you have Revive installed, uninstall it

  d.  If you have Oculus installed, uninstall it

  e.  (This one hurts)  Uninstall Steam.  Yes, in my experience, you have to do it.  Yes, you'll have to reinstall your    games.  Would've been nice for HTC to think about that before they released the Vive Pro setup software, but it is what it is.

2)  Do a clean install of your graphics card's most current drivers.

3)  Turn off your computer

4)  Disconnect ALL of your Vive equipment & unplug base stations (make sure NOTHING related to the Vive is connected to the computer)

5)  Restart the Computer


--At this point, you should be starting fresh, so proceed as follows--


6)  Download the Vive PRO Setup program (NOT the Vive Setup Program or Vive Pro HMD Setup) from vive.com/setup/vive-pro 

7)  Run the Vive Pro Setup program, reconnect your equipment as instructed by the Vive Pro Setup program, and follow the directions EXACTLY to the letter (for example, make sure your play space is EMPTY before you attempt to run room setup)


At this point, installation should work.  You'll get a clean copy of Steam / Steam VR and your entire system will be reconfigured.  The ONLY error you should see is "Steam VR Not Ready / Run Room Setup" prior to your running room setup, but you shouldn't get the headset tracking errors, etc.  However, after ALL of this, if you STILL get the "Compositor Not Ready" error, there's a bad configuration file.  Here's how to fix THAT problem:


1) Close both Steam and Steam VR

2) On your computer, browse to the folder /steam/config

3) Delete the file labeled something to the effect of "settingsvr" (one of the last files listed in the /config/ folder. 

4) Restart STEAM (not Steam VR)

5) Enter VR from within Steam, and run room setup again.  You will be able to complete setup, and this will fix the "Compositor not ready" error.


Last thing:  I've found that with the Vive Pro system, you can no longer launch Steam VR independently of Steam without creating dozens of errors.  To enter VR with the Vive Pro, you have to open Steam and then click the VR icon up top.  In other words, you need to let Steam launch Steam VR.  Don't try to launch Steam VR on its own.


I know this is a lot, but I wanted to share my experience in the event that it helps someone else.  Yep, it's a pain, but once the setup is done, totally worth it.

Link to comment
Share on other sites

I'm going to try this and hope it works. I got the Pro bundle and it's been three days of troubleshooting. Simply, the base stations will not track or show as detected in Steam VR. I'm at the end of my rope. 


 I remounted in a smaller space, power cycled the base stations, alternated USB ports, tried the Steam VR Beta, held the channel button while on and off - nothing. HTC CS didn't know either so they're going to call me back later this week. I've uninstalled the drivers through Steam VR multiple times (is basic window uninstall sufficient?). Plugging in the base station via USB doesnt allow me to update it, just access it in my computer. 


I uploaded my VRServer.txt here as well: https://drive.google.com/open?id=1iQ5mFVTnXVKWnZwSIG1CD_lWoIyWmHfn

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...