Jump to content
Happy Holidays! Limited Staff Responses: 1/20 - 1/31 ×

Arts Experiments with Google


JohnEBoy
 Share

Recommended Posts

Hi all,

 

I'm new to this VR business and have recently purchased a HTC Vive.

 

It is setup and running fine.

 

I've downloaded some games from Steam and been able to use these including using an XBOX gamepad.

 

However, one thing I cannot get to work, is the following site:

 

https://artsexperiments.withgoogle.com/bagan

 

I've followed the instructions at the bottom of the page to enable the 4 Chrome flags and I have SteamVR running prior to launching the site.

 

Once within the Temple itself, I cannot find a button Enable WebVR on the screen anywhere, so I cannot see it within the headset.

 

The only thing I note on the first page is "Lab experiment requires WebGL" and I am not sure if I have this.

 

I cannot find much knowledge on this.

 

Can anyone help?

 

Many thanks,

 

John

Link to comment
Share on other sites

Hi!

What browser are you using?

I had such a problem using another site requiring WebGL and here is what I discover.

Try this site first : https://get.webgl.org/

Here are some setting I found during my previous research on the subject:

With Chrome, type "about:flags" in the adress bar and look for WebGL. Activate it.

With Firefox, type "about:config" and search "webgl.force-enabled" and set the value to "true". Also, search "webgl.disabled" and disable it. (if it exists)

Unfortunately, my laptop didn't support it so I didn't push my exploration further. If anyone knows more than I do about this please feel free to help! This was the result of my research on the web and I am not a wizard on the subject.

Hope I could help!

Max

Link to comment
Share on other sites

Hi,

 

Thanks for your reply!

 

I setup a fully updated Windows 10 install from scratch on the machine I am using for VR and I literally installed Chrome just before trying it out (so without looking I guess the latest as of yesterday!).

 

I will give your suggestion a try shortly when I am able!

 

I will post up with the results...

 

Thanks again.

 

John

 

 

Link to comment
Share on other sites

, webXR/webXR is still in it's formative years - I've found that I often have to cycle between different compatible browsers depending on the specific site I'm trying to load as different sites are in vastly different stages of implementation. I've been having the most luck with Firefox lately but I've yet to find a browser that will work universally. Servo has worked a few times when others did not. Sketchfab is my favorite webXR platform currently.

 

You can use these sample projects to debug webXR: https://webvr.info/samples/ 

Link to comment
Share on other sites

Hi all,

 

 - so I had a go at this. The https://get.webgl.org/ site showed the spinning cube and stated I had it installed correctly. It was set to default in Chrome so I enabled it and re-launched the browser.

 

Still no joy although I don't know where the button you are supposed to press is. Certainly doesn't appear where the notes state it will.

 

 - thanks for that. I will try Firefox. I will also try other demos as it could just be an issue with that one.

 

 

Thanks again!

Link to comment
Share on other sites

Hi again,

 

So I tried another demo in the Arts Experiments in Google but still no button.

 

Then I tried Firefox (I had to set "webgl.force-enabled" to true - "webgl.disabled" was false already) and the Bagan one loaded and there was the button.

 

For anyone reading this with the same issue - it will appear near the bottom right to the left of where you can change the detail level through Low, Medium and High.

 

I naturally presumed the latest Chrome would work but as above, it seems to be a case of not all browsers supporting all VR yet.

 

Thanks a lot folks!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...