Jump to content
Happy Holidays! Limited Staff Responses: 1/20 - 1/31 ×

Vive Pro - USB Issues "Device Descriptor Request Failed"


rdstudio
 Share

Recommended Posts

Hello Tech Support,

 

Recieved our Pro last week. Plugged it in; worked fine. It seems we got a Windows update last week (1803) and now we get USB errors when we plug it in.  In the device manager it shows up as "Unknown USB Device (Device Descriptor Request Failed)". I've heard there have been some issues with 1803. Wondering what I should do with this paperweight. Thanks!

 

Here are my specs:

Alienware AREA51R2

Intel i7-5820K

GeForce GTX 1070

Windows 10 Pro 1803

Link to comment
Share on other sites

Hey John,

 

Thanks for the quick response. I just rolled back Windows to version 1709. Same problem occurs so apparently it wasn't the Windows Update that caused my problem. Thoughts on what we should try next?

 

Thanks,

Mark

Link to comment
Share on other sites

So I tried setting it up on a different PC. Same problem. When I plug it into USB3 I get that "Device Descriptor" error. When I plug it into USB2 it doesn't throw an error but it still fails to detech a headset. 

Link to comment
Share on other sites

  • 2 months later...

I am having the exact same issue with mine. It seems sometimes I can remove all the devices, restart, and try various USB ports, and SOMETIMES I get it to work, sometimes on USB3, other times on USB 2. I wish I knew why it was throwing these errors. It would be nice if we were provided a place to just DOWNLOAD THE DRIVERS so we wouldn't have to deal with this.

Link to comment
Share on other sites

  • 1 year later...

Hey…this same thing happened with me also. So, nothing to worry anymore, just uninstall the USB Driver in the Device Manager to fix unknown USB Device (Device Descriptor Request Failed) error. Because this method helped me a lot to resolve USB device failed issue easily.

To do so, you have to open Device Manager and expand category Universal Serial Bus ControllersLocate the USB device which is not being recognized by Windows. Then right-click the device and choose Uninstall from context menu. After this, restart your PC then Windows will reinstall the device automatically.

Link to comment
Share on other sites

  • 1 month later...

Device Descriptor request failed error occurs, mostly due to USB power settings. There is particular USB selective suspend setting in USB Power setting management is responsible for this error. You need to disable disable USB selective suspend setting.

To change this just go to Windows power options and change power settings. Under Power settings, you will find advanced power settings. Click on  USB settings under advanced settings and disable USB selective suspend setting. Now hit OK. it should fix your problem as i was able to fix mine.

When i encountered same problem few days back, i search through many blogs on internet and found one blog that helped me fix my USB Device Descriptor request failed error, if you want You can check too, for better understanding and for other suggested methods.

Link to comment
Share on other sites

  • 1 year later...

Hello everyone, hope you are all well.

I've been having an ongoing issue that started over a year ago with my laptop. One day out of the blue one of the USB ports decided to not recognize anything I insert.
I've tried multiple devices with the same result. When I insert a USB device the notification sound plays that the device has connected and then it disconnects and says that
the device is not recognized. Recently however I connected an external hard drive and it remained connected for longer than usual, about 5 seconds. I was about to click into it when it disconnected.
 

330367


I have check multiple websites for fixes and followed some of them with no success. Here is some of the stuff I tried:

  • Uninstalling all the devices in the Universal Serial Bus Controllers and then restarting.
  • Updating the drivers for all the USB devices and restarting.
  • Running a "chkdsk" command prompt thing that didn't seem to do much.
  • Attempting to follow the instructions of a SOLVED post on TomsHardware that required going into the registry and deleting stuff but I didn't continue as I was unsure.

Below I've listed the specs of my laptop just in case it's useful:

  • Acer Predator Helios 300
  • Windows 10 Home 64bit (Up to date)
  • Intel i5 8300H 2.30GHz
  • 8GB DDR 4 RAM 2666MHz
  • Nvidia Geforce GTX 1060 6GB DDR5
  • Samsung 960 EVO SSD 250GB
  • 1TB Hard Drive
  • Laptop is 2 years old.

The laptop is in excellent condition as I take care of my stuff. I hardly ever use the laptops keyboard and track pad as I have a USB keyboard and mouse. The laptop looks new.

NOTE: I have sent an email to Acer so waiting to hear back from them, if ever...

So any idea how to correct this issue with the USB port?
Thanks for reading.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...