Jump to content
Happy Holidays! Limited Staff Responses: 1/20 - 1/31 ×

Firmware loops and Tracking issues (vive - not vive pro)


KDS
 Share

Recommended Posts

 
I used my vive on my laptop (MSI GS65 with 1070 MaxQ) before coming out to college. everything worked like a dream. i just had it ship out to me well packaged and set it up. now I'm having a ton of issues such as.

-Unplugging link-box USB/resetting link box causes head set or controller to require firm ware updates on occasion. (the same one over and over again)

-head set and controller tracks fine but on launch of some steam games most notably job simulator cause both controlers and link box to stop tracking and for the light houses to grey out.

-Some games work but after some time will have one controller stop tracking and remain where it was in game. identifying the controller will fix it but the issue re occurs within one minute from doing so

-Head set occasionally will grey out and lose tracking. the only fix for this is many restart and I'm lucky it will work long enough for a single song on beat saber. 

-In device manager the Bluetooth driver "Broadcom BCM20703 Bluetooth USB Device" states "This device cannot start. (Code 10)

{Operation Failed}
The requested operation was unsuccessful."

-Under Bluetooth & other devices in windows under other devices "BCM2045A0" states "Driver error"

I have tried:
-different angles and positions for light houses all withing Vives recommended set up range. 6.5 feet up no more than 15 feet apart etc

-Resting link box and unplugging the USB on the lap top side for the link box

-Different ports for the USB from the link box.

-Updating all my computers drivers including graphics drivers

-reinstalling all drivers for Bluetooth manually removing them and using the option on the steam VR settings. 

-Restarting my computer. duh.

-re-pairing controllers.

- Uninstalling steam VR and verifying integrity. 

-Launching games before and after launching steam VR

My best guess is that the link box is bad but I don't want to spend the money only to find out it was fine and still have all these issues. i should also note when i can get everything working the steam home room menu thing will work fine. no issues at all for as long I stay there.
Link to comment
Share on other sites

 have you tried completely bypassing both the HDMI and USB on the linkbox and instead plugging both of these leads directly into the Laptop? Overall, linkboxes rarely fail but it's not uncommon for different OEM hardware to establish and HDCP session with the HMD - one way to help alleviate this behavior is the bypass I mentioned. Have you tried other USB ports on the laptop?

 

Are you using the stock OS image - the factory image on these MSI's is kinda sucky. I've personally had similar issues with MSI's be resolved with clean OS image. 

 

The firmware boot loop is typically related to USB host issues - if it's just updating to the same firmware version I would disregard the notification 

Link to comment
Share on other sites

  • 2 weeks later...

Hi! Sorry for the slow response. I haven't tried it but I will. I believe the issues on software side. My laptop is on the windows 10 copy that it came with. No tampering other than little think like power management. I made sure to apply all os updates before doing more troubleshooting. I have also found it only acts up in some games. In fallout 4 vr, vr chat, and usually beat saber it has no issues. I haven't looked farther into it as those are all I play and they work fine. I will look more into the issues soft ware wise and I'll test like you mentioned to rule out the link box. I'll be sure to further update this thread as I find out more. Thank you!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...