Jump to content

"Connection refused: localhost:[port]" when trying to install software


Recommended Posts

As the title says, I'm trying to sign in to my HTC account in the Vive installer, but when I click "login," I get this error, "Connection refused: localhost:[port]" followed by a random port in the 32000 range.


I tried searching for an answer and nobody has had this issue ever, it seems.

EDIT: I managed to get the link that it is trying to reach:

I still don't know why it is trying to redirect to localhost.

Link to comment
Share on other sites


I've pinged the installer team for assistance on your specific issue as it's not a common one. If possible, it would be helpful if you could upload and PM me the installer logs from your specific case as they'll provide more specific hints as to what's happening. 


The installer logs' location varies depending on your windows setup. You can typically find them by searching your primary harddrive for "localappdata\temp\ViveInstall" and locating the logs contained within. 


On that note, aside from windows defender, do you have any third party firewall or network monitor tools (sometimes they can be OEM tools)? 

Link to comment
Share on other sites

, so the installer successfully worked? 

I heard back from the installer team overnight. A firewall (which can be on your PC, on your modem/router, or even at the ISP level) would really be the main source of this error message. The port itself may be closed on your modem. The other option is that the port in question is not listening. They recommended you use this guide to check if the port is listening. 

Link to comment
Share on other sites

  • 2 years later...

I have the same Problem. When i press login on the installere it opens a link but it cant finde tha page.

this is the link i get: http://%22https//www.htcsense.com/$SS$/Services/OAuth/Authorize?response_type=code&client_id=cb2340ce-2cc4-46f8-ac05-f75d40a96699&scope=issuetoken%20email%20birthday%20profile.write%20payment.security.write&redirection_url=http%3A%2F%2Flocalhost%3A59329%22 

Im sorry that my screenshot is in german but its written that it cant find the page

Screenshot 2020-12-25 123351.png

Link to comment
Share on other sites

@Lgonzal002 @ilves404 @Mrlincolnlog

We've found an issue specific to the Vive Pro installer. Please see this FAQ and use the suggested install link: https://service.viveport.com/hc/en-us/articles/360054317612-Enterprise-VIVE-Pro-Setup-download-failed-issue

In a worse case scenario, the only thing you need to run the base hardware is SteamVR itself which can be downloaded from Steam.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...