Jump to content

Error 400 (Compositor not available) - Symptoms and Solutions


Recommended Posts

Error 400 is usually caused by multiple monitors plugged into the PC. Make sure that the link box is plugged into the same graphic card with the main monitor. You can change which is the main monitor in right click – display settings. If it is still not working, unplug other monitors. Try updating the graphics driver as well.


Link to comment
Share on other sites

  • 11 months later...

After 8 hours of configuration still nothing!!!!!

Own a DELL with two graphic cards, tried to disable one and the second one but nothing!!!

VIVO soft ware is CRAP!!!!! When you sell thy you should consider also people like me!!!!!


Link to comment
Share on other sites

I have a Dell XPS 15 With Intel Core i5 6300HQ processor


Video Intel HD GRaphics 530 and NVIDIA GeForce GTX 960M

Windows 10 PRO

Ggetting Compositori not available, tried toi open conpusitori*clicking the link provided( but nothing start

I have tried to run it with Direct Mode ENABLED or DISABLED but nothing works,,,,,,

Link to comment
Share on other sites



Had this worked before?

The specs you listed are unfortunately below the threshhold for a VR ready machine (I'm not saying this is the cause) and once the output does come out it will potentially result in a poor experience because of how the 960m is configured (which has 2GB of memory if I recall for that chip in that laptop).


Take a look at this thread on nVidia for an explanation of the implementation (optimus link to the internal GPU): https://forums.geforce.com/default/topic/937700/nvidia-960m-and-steamvr-performance-test/?offset=3


With that said, try the below and let me know if it gets you closer to working:


Use USBDeview to manually uninstall drivers
USBDeview is a free tool that is automatically included with the installation of SteamVR. The default path to this tool is …\Steam\steamapps\common\SteamVR\tools\bin\win32\thirdparty. This tool allows users to manually inspect all USB devices that have installed drivers, and is useful when it is suspected the Vive drivers are not being removed using the SteamVR ‘Remove all SteamVR USB Devices’ feature, or when it is believed there may be conflicts caused by other USB devices. Non-Vive related USB devices should only be uninstalled in this way if there is believed to be a driver conflict caused by another USB device.

Removing Vive USB Drivers

  1. Disconnect all Vive cables from the PC.
  2. Launch the USBDeview program.
  3. From the Options tab, enable Display Disconnected Devices.
  4. Sort the list of devices by VendorID (click VendorID at the top of the list).
  5. Locate any devices with VendorID 28de (these are the Vive components) and uninstall them.
    1. To uninstall, right click the device and select Uninstall Selected Device. You may need to click Yes to confirm the selection.
  6. After uninstalling all devices with the 28de in the VendorID column, close USBDeview and reboot the PC.
  7. Reconnect the Vive cables to the PC. Ensure all cables are properly connected and then launch SteamVR. This will begin the re-installation of the Vive related drivers.

Make sure direct mode is enabled.  Make sure to plug in directly to the USB on the machine and not via a hub just to make sure no conflicts. Plug the HDMI cable directly from the PC to the linkbox.


Let me know if this provides you with any progress.  


Thank you,




Link to comment
Share on other sites

  • 5 weeks later...
  • 2 months later...


The 960M is indeed below the thresholds of what can run VR (Our min spec is a GTX 970 and we're now recommending a 1060 nowadays). Laptops with onboard graphics handle HMDI output in weird ways and thus you may have some luck playing with direct/extended modes. That said, if you do get the compositor to successfully detect your graphics card, I wouldn't expect usable performance out of a 960M. The 960M benchmarks at about a third of what the 970 benchmarks at for comparison. 

Link to comment
Share on other sites

I did the steps you outlined above for USBDeview but still get the issue. I should also note that when i hooked everything up again after a reboot i didn't see any 'installing devices' prompts. I've been trying to get this issue fixed for 6 hours with no luck. i'm also on an asus laptop but have a 980m - well aware it is below the recommendation but still - usb and other things should at least be recognized.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...