Jump to content

Vive SRworks SDK does not work. Unity freezes.


yuta
 Share

Recommended Posts

Hi, I've struggled to use ViveSR with my Vive Pro (upgrade version).
I'm using "Vive-SRWorks-0.7.5.0" and "Vive-SRWorks-Patch-0.7.5.3".
I already confirmed the front cameras are working fine by running the test in "SteamVR/Setting/Camera".


First, I launched the builded apps.
Both "Vive SRWorks Demo" and "Vive SRWorks" show "(Not Responding)" imeadeately after launch.
This is the log.

 

```

[Vive SRWorks] [2018-10-20 19:07:36] [LOG] ViveSR_Initial() success
[Vive SRWorks] [2018-10-20 19:07:36] [LOG] SRWorks Version 0.7.5.0
[Vive SRWorks] [2018-10-20 19:07:36] [LOG] CPU : Windows 8+
[Vive SRWorks] [2018-10-20 19:07:36] [LOG] CPU GetMemory Total : 16348.000000
[Vive SRWorks] [2018-10-20 19:07:36] [LOG] CPU GetMemory InUse : 4892.000000
[Vive SRWorks] [2018-10-20 19:07:36] [LOG] GPU : GeForce GTX 1080 Ti
[Vive SRWorks] [2018-10-20 19:07:36] [LOG] GPU driver : 41634
[Vive SRWorks] [2018-10-20 19:07:36] [LOG] GPU memory usage : 2916.246094
[Vive SRWorks] [2018-10-20 19:07:36] [LOG] GPU memory loading: 17
[Vive SRWorks] [2018-10-20 19:07:36] [LOG] ViveSR_CreateModule() start
[JSON] [2018-10-20 19:07:36] [LOG] found steam install path
[JSON] [2018-10-20 19:07:36] [LOG] using device : LHR-FACF0434
[JSON] [2018-10-20 19:07:36] [LOG] using system : lighthouse
[JSON] [2018-10-20 19:07:37] [LOG] found device config file : C:/Program Files (x86)/Steam/config\lighthouse\LHR-FACF0434\config.json
[JSON] [2018-10-20 19:07:37] [LOG] Cali_V2D_00000
[JSON] [2018-10-20 19:07:37] [LOG] MIE_GCP_00000
[JSON] [2018-10-20 19:07:37] [LOG] found steam install path
[JSON] [2018-10-20 19:07:37] [LOG] using device : LHR-FACF0434
[JSON] [2018-10-20 19:07:37] [LOG] using system : lighthouse
[JSON] [2018-10-20 19:07:37] [LOG] found device config file : C:/Program Files (x86)/Steam/config\lighthouse\LHR-FACF0434\config.json
[JSON] [2018-10-20 19:07:37] [LOG] Cali_V2D_00000
[JSON] [2018-10-20 19:07:37] [LOG] MIE_GCP_00000
[Vive SRWorks] [2018-10-20 19:07:37] [LOG] SeeThroughModuleSetDevice:: D3DDevice
[Vive SRWorks] [2018-10-20 19:07:37] [LOG] CM_MT1_MID0_00000
[Vive SRWorks] [2018-10-20 19:07:37] [LOG] ViveSR_CreateModule() end
[Vive SRWorks] [2018-10-20 19:07:37] [LOG] ViveSR_CreateModule() start
[Vive SRWorks] [2018-10-20 19:07:37] [LOG] CM_MT4_MID2_00000
[Vive SRWorks] [2018-10-20 19:07:37] [LOG] ViveSR_CreateModule() end
[Vive SRWorks] [2018-10-20 19:07:37] [LOG] ViveSR_CreateModule() start
[Vive SRWorks] [2018-10-20 19:07:37] [LOG] ReconsModuleSetDevice:: D3DDevice
[Vive SRWorks] [2018-10-20 19:07:37] [LOG] CM_MT5_MID4_00000
[Vive SRWorks] [2018-10-20 19:07:37] [LOG] ViveSR_CreateModule() end
[Vive SRWorks] [2018-10-20 19:07:37] [LOG] SM0ViveSR_StartModule() start
[Vive SRWorks] [2018-10-20 19:07:37] [LOG] SM0ViveSR_StartModule() check pass
[DEVICE_VIVE_HMD_DUALCAM_0_DLL] [2018-10-20 19:07:37] [LOG] initialization mode 2-2
[DEVICE_VIVE_HMD_DUALCAM_0_DLL] [2018-10-20 19:07:37] [LOG] Create Mapping table start
[DEVICE_VIVE_HMD_DUALCAM_0_DLL] [2018-10-20 19:07:37] [LOG] Create Mapping table end
[DEVICE_VIVE_HMD_DUALCAM_0_DLL] [2018-10-20 19:07:37] [LOG] Create Mapping table start
[DEVICE_VIVE_HMD_DUALCAM_0_DLL] [2018-10-20 19:07:37] [LOG] Create Mapping table end
[DEVICE_VIVE_HMD_DUALCAM_0_DLL] [2018-10-20 19:07:37] [LOG] initialization mode end2-2
[Vive SRWorks] [2018-10-20 19:07:37] [LOG] SM0ViveSR_StartModule() initial end
[Vive SRWorks] [2018-10-20 19:07:37] [LOG] SM0ViveSR_StartModule() initial pass
[DEVICE_VIVE_HMD_DUALCAM_0_DLL] [2018-10-20 19:07:40] [LOG] TurnOn
[DEVICE_VIVE_HMD_DUALCAM_0_DLL] [2018-10-20 19:07:40] [LOG] loading undistortion parameters start

```


Next, I tried to use it in Unity.
I imported SteamVR from the asset store and ViveSR via custom package,and loaded "ViveSR/Scenes/Sample/Sample.scene".
When I pressed play button, Unity freezes with following consule output.

 


I could not find the exact same topic in this forum or Google search result.

 

 

 

Link to comment
Share on other sites

  • 2 weeks later...
  • 2 weeks later...
  • 3 years later...

My users and I are similarly experiencing complete unresponsiveness whenever the SRWorks SDK is invoked with a Vive Pro, including with the sample application. Here's the logs from the SRWorks_v0.9.7.1_Unity_Prebuild_Samples app: @Daniel_Y

Initialize engine version: 2017.4.17f1 (05307cddbb71)
GfxDevice: creating device client; threaded=1
Direct3D:
    Version:  Direct3D 11.0 [level 11.1]
    Renderer: NVIDIA Quadro RTX 6000 (ID=0x1e30)
    Vendor:   NVIDIA
    VRAM:     24276 MB
    Driver:   30.0.15.1109
Begin MonoManager ReloadAssembly
- Completed reload, in  0.049 seconds
<RI> Initializing input.

<RI> Input initialized.

<RI> Initialized touch support.

OpenVR initialized!
 
(Filename:  Line: 672)

UnloadTime: 146.991200 ms
<b>[SteamVR]</b> Successfully loaded 21 actions from action manifest into SteamVR (D:/Archiving/ThirdParty/SRWorks_v0.9.7.1_Unity_Prebuild_Samples/Build-Unity/Experience/Vive_SRWorks_Demo_Data/StreamingAssets\SteamVR\actions.json)
 
(Filename: C:\buildslave\unity\build\artifacts/generated/common/runtime/DebugBindings.gen.cpp Line: 51)

<b>[SteamVR]</b> Initialized. Connected to lighthouse:LHR-259BDE66
 
(Filename: C:\buildslave\unity\build\artifacts/generated/common/runtime/DebugBindings.gen.cpp Line: 51)

[ViveSR Experience] Waiting for ViveSR
 
(Filename: C:\buildslave\unity\build\artifacts/generated/common/runtime/DebugBindings.gen.cpp Line: 51)

I also have confirmed that the "Test Camera" option of SteamVR displays the camera feeds correctly, so that doesn't seem to be the issue. Would love to have this option available to users but this definitely isn't functional at the moment.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...