Jump to content
Happy Holidays! Limited Staff Responses: 1/20 - 1/31 ×

Intel(R) MA-USB Host PAL Code 31


Spikeone
 Share

Recommended Posts

 Hello together,

 

I just got the wireless vive adapter and installed it on my PC. Pairing the device using the app worked fine. Yet after few seconds I was told that my headset couldn't be detected and I may unplug and plug back the USB cable or just wait some minutes. I did both and it still didn't work. So I decided to check this forum (and the mighty internet) for the reason and couldn't find much except "Updating from Win7 to Win10 helped" or something similar. Yet someone pointed out that he had problems installing all USB devides - so I checked the device manager and yes, I got a similar problem. The Intel® MA-USB Host PAL does not work properly because the needed driver couldn't be loaded. I searcherd the internet for a driver and tried to install them, yet the installation told me "you are using the latest driver". So I'm not sure how to fix that problem at all but you guys may help me.

Wireless App:

App Systeminfo:

 

Systeminfo:

Hope someone may help me. 

Solutions I may not test: Reinstalling the OS

 

If there is any log or information that may help, just ask, I'll gladly help.

 

Best regards Spike

 

 

Link to comment
Share on other sites

Hello,

I'm suffering the exact same issue, but sadly no resolution so far and HTC have yet to respond to my ticket request. Items that I've tried to resolve or diagnose the issue are;

  • Swapping PCI slots.
  • Short headset wire to wired box (works), long headset wire to wireless unit (same issue).
  • Disconnecting wired box completely (not just USB+Power).
  • Uninstall / Reinstall Vive Wireless software.
  • Reinstalled the OS.
  • Uninstalled various ASUS USB drivers.
  • Revert HMD to wired ( HMD works on wired immediately without issue)

There doesn't appear to be much in common between our systems. I've an Asus X99-M WS motherboard, not MSI. GTX970 card, not 1080 Ti. The only thing in common is the actual processor type and Windows 7 (at different versions and levels).

 

Therefore the only constructive item I can offer right now is that a re-install of Windows 7 is unlikely to address the issue you're seeing. I'll keep at it and let you know if I find a fix.

 

Regards,

Steven.

 

 

Link to comment
Share on other sites

He Scalvert,

 

It really does help me a lot, that doing a clean OS installation does not help at all as I was afraid that'd be the one and only solution for the problem.

Guess there is at least no solution yet so I have to sadly send the adapter back. Don't need an other wireless adapter I'm not using ;)

 

Thanks for that information anyway :-/ It'd be quite nice to know which windows 7 version they used for testing as in another post they said they do test on win7.

 

Best Regards

Spike

Link to comment
Share on other sites

I'm having the same problem. Can't find the headset and this driver is not loaded with Error code 31. I also tried to use the Intel Driver  & Support Assistang but it can't properly work.

Very frustrating. It says there is support for Windows 7 SP1 and it's a very expensive piece of hardware on top of another very expensive piece of hardware and then it doesn't work because a driver doesn't load.

Link to comment
Share on other sites

Sorry to pile on. But I purchased this device too, in anticipation of upgrading to the Pro. The website and documentation very clearly states compatibility with Windows 7 SP1. And btw, if you are using SteamVR, you are on SP1. SteamVR will not install without it. That said. The Vive wireless device will not work because the WiGig drivers for Win 7 will not install. I know my way around these issues so I even attempted to modify similar drivers. Fail.

I guess they figured once we spent the money, we would keep the device regardless. No fix. No sale! RMAed!!

 

Google the other issues Win 10 users are having with performance. I will keep enjoying my Vive and TPCAST with opentpcast software.

Link to comment
Share on other sites

I also have Windows 7 and experiencing exactly the same issue, I bought it over a month ago and still did not manage to make it work. I left multiple messages on forum and emails, I did not get any replies and no one told me to fix it anytime soon. This is how HTC works here.

Link to comment
Share on other sites

With the latest Update it works for me! :-) And it's great. I hope you can get the Update too.

It showed when I opened the Wireless App and said Update available. After installing it worked without any further actions.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...