Jump to content
Happy Holidays! Limited Staff Responses: 1/20 - 1/31 ×

SRWorksHand


BentelAnn
 Share

Recommended Posts

Hi everybody,

I've downloaded and opened the Hand Tracking demo from here: https://github.com/ViveSoftware/ViveSRWorksHand

I've added the SteamVR and SRworks plugins and I've also update the dll contained in the SRworks patch, I'm running Unity 2018.2.5f1.

The HandScene runs and tracks the hmd movements but Im not able to see the Virtual objects and to interact with them. Does anybody have the same problem?

 

Link to comment
Share on other sites

  • 2 weeks later...

Thanks for your response,

The cameras actually work, in the hmd I was seeing through them, what I was seeing is shown in the picture, in the hmd mirror next to the Unity window.

However, yes, it seems that they don't communicate with Unity (in the game view I don't see the real world and my hands are not tracked) and that Unity doesn't communicate with them (the virtual objects are not shown in my hmd if the cameras are on).

Is there some setting I'm missing to check? Is there a way to debug the cameras?

Thanks

Link to comment
Share on other sites

SRWorksHand is currently being updated for v0.8.0.2 today - that will not fix your basic problem of not having SR working  - can you you run the experience build? (any version)

 

please send your srworks log file - and again double check the cameras are working in Steam settings, also waht GPU are you using?

 

Link to comment
Share on other sites

All the build fail to run, they freeze, except for the ViveSRWorksHand, which runs but doesn't let me interact with the objects neither to see the room. If I check "Allow camera for chaperone bounds" I'm able to see the room but not the virtual objects.

 

Link to comment
Share on other sites

RECONSTRUCTION LOG:

[Reconstruction Engine] [2018-11-15 16:02:18] [LOG] Set DataSource:0
[Reconstruction Engine] [2018-11-15 16:02:18] [LOG] Set not to use sensor device
[Reconstruction Engine] [2018-11-15 16:40:47] [LOG] ViveStaticReconstruction Destruction

[Reconstruction Engine] [2018-11-15 16:41:07] [LOG] Set DataSource:0
[Reconstruction Engine] [2018-11-15 16:41:07] [LOG] Set not to use sensor device
[Reconstruction Engine] [2018-11-15 16:47:34] [LOG] ViveStaticReconstruction Destruction

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...