Jump to content

ViveWirelessSetup coming up with "Fail to install Intel WiGig. Please reboot PC and try again."


Recommended Posts

Wireless Linkbox and PCI card are installed, blue indicator light is on. Wireless adapter/receiver is connected to the Vive headset. 

The first time I tried to install using the download, "ViveWirelessSetup", the computer went to a reboot screen after encountering an error, and took some time to formulate and send information to Microsoft, then rebooted on its own. When I tried again, it did not reboot automatically, but gave me a small window with the error message, "Fail to install Intel WiGig. Please reboot PC and try again." Rebooting and trying again did not work. I've tried reinstalling SteamVR and trying the ViveWirelessSetup again, but this hasn't worked for me. I also tried using the .msi to repair DisplayLink, and it did not change the behavior of the installer. 

Computer Specs:
OS: Windows 10 x64-bit - fully up to date

GFX Card: Nvidia GTX1080 - Founders Edition

Motherboard: ASRock X79 Extreme9 Motherboard
CPU: Intel Core @ 3.70GHz / Ivy Bridge-E/EP 22nm Technology


Link to comment
Share on other sites

I'd also like to point out that the Steam VR is installed in the default path C:\Program Files (x86)\Steam\steamapps\common\SteamVR, so this could not be the issue.

I just looked through the Device Manager in the Control Panel, and it does show "Intel Wireless Gigabit VR Adapters", with two different items contained within. 
-Intel Wireless Gigabit Software Device  ("This device is working properly." Location 0 (iWiGiG device))
-Intel Wireless Gigabit W11100 VR Device ("This device is working properly." PCI Bus 3, Device 0, Funciton 0)

Looking into both of the items properties and trying to update drivers there comes up with "Drivers up to date" and "This device is working properly." messages. I'm not sure if these are the drivers required to run the headset... but it seems as if those are actually working according to Windows. I'm not sure if these are related to the WiGig drivers that are required to run the Vive Wireless Adapter though. (This is very confusing)

I have seen that some others have been successful in reformatting their computers and installing everything from scratch, but this may be complicated for me atm, due to the fact that I have so much stored on my drives that I could not possibly fit all of it on any external storage device(s). I will try to figure out a solution to that, as a last resort, but in the mean time I would really like to figure out a solution that doesnt require a full format. Any help or insight is appreciated!

Link to comment
Share on other sites

  • 2 months later...

This is how I fixed mine:


Go to device manager.  If you do not show "Intel wireless gigabit VR Adapters" on its own line, you will have an unknown device.


Go into the properties of the unknown device and choose update driver.


"Intel wireless gigabit VR Adapters" should now show and you can now successfully run the Vive Wiresless setup





Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...