Jump to content
Happy Holidays! Limited Staff Responses: 1/20 - 1/31 ×

Desktop App broken since failed update - can not reinstall - version mismatch?


Schwuuuuup
 Share

Recommended Posts

My Viveport Desktop App said it had to update.

The Computer Crashed while Updating (may not be related)

Now I Cannot use the Desktop App

 

I rebootet and uninstalled several times but everytime I Install it states that there is a File Missing from 

C:\ProgramData\Package Cache\{BEB75738-FA08-48DE-B0B9-6C73D7236330}v1.2.9.52\ViveportDesktop.Package.x86.msi

 

BUT!!!: There is a file:

C:\ProgramData\Package Cache\{400F514F-2762-4C2A-9DCA-645AA89A7AF0}v1.2.9.56\ViveportDesktop.Package.x86.msi

 

To me it seems as there is a version mismatch in the installer: 1.2.9.52 vs. 1.2.9.56

 

Have you messed up the Setup.exe?

 

Link to comment
Share on other sites

Hi,

 

Of cause I already opened a ticket the other day.

Today I got a reply:

 

 

Could you please try this steps

1. download microsoft force uninstall msi tool from https://support.microsoft.com/en-us/help/17588/fix-problems-that-block-programs-from-being-installed-or-removed

2. use this tool force uninstall these components

3. Download https://dl.vive.com/oobe/VIVE/ViveSetup.exe and install again

 

But in the meantime I solved the problem by installing it on another computer and then copy over the Vive folder.

 

Maybe somewhere in the innards of Windows there a those pesky files that tell it to install the wrong file versions, but it's working now an the desktop app already succeeded in updating itself

 

Link to comment
Share on other sites

Ok, the Vive Desktop App starts and is usable... but it tries to update now everytime it launches. 

The Update seems to be the update to 1.2.9.56 and it installs sucessfully. but on nex start it wants to update again. Furtunately you can click on "later".

So the state is "usable for now but not solved".

I guess there is some Registry Entry that is confused about the versions.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...