Jump to content

DisplayLink XR Issue after attempting to update to 1.20190410.0


bobxor

Recommended Posts

This morning I saw a Vive Wireless app update, shortly after clicking "Update Now" the computer completely froze.  I waited 15 minutes with no update (clock was stuck in time).

 

After rebooting, when attempting the update again I keep getting the error "Fail to install DisplayLink".  I uninstalled Vive Wireless, uninstalled SteamVR, reinstalled SteamVR, and attempted to reinstall Vive Wireless.

I still get the same error.  Looking at the log I think the issue is here:

MSI (s) (D8:FC) [13:39:07:101]: SOURCEMGMT: Failed to resolve sourceMSI (s) (D8:18) [13:39:07:102]: Note: 1: 1714 2: DisplayLink XR 3: 1612 CustomAction returned actual error code 1612 (note this may not be 100% accurate if translation happened inside sandbox)MSI (s) (D8:18) [13:39:07:102]: Product: DisplayLink XR -- Error 1714. The older version of DisplayLink XR cannot be removed. Contact your technical support group. System Error 1612.

I've tried everything I could find on the web to get around this issue to no avail.  

I also tried running DisplayLinkXR.msi (in the VIveWireless folder).  The installer gets to "Removing applications", then pops up with "The feature you are trying to use is on a network resource that is unavailable."  Clicking cancel gives the similar error "The older version of DisplayLink XR cannot be removed.  Contact your technical support group."

Link to comment
Share on other sites

If anyone else runs into this issue, I did find a solution.  I had to search and delete every single "DisplayLink" entry in my Windows Registry.  After doing that, the installation off DisplayLink succeeded and the Vive Wireless install continued without further issue.  

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...