Jump to content

Cosmos Headset Not nor has worked


Recommended Posts

5 hours ago, T said:

Googling your VBIOS version of 86.04.7D.00.29 brings me to this result :

So at least for the GTX 1070 at the MSI GE63 Raider RGB 8RF laptop the 86.04.7D.00.29 VBIOS is broken for the Rift S and there is an updated version for it that fixed it. Also from the same thread the updated version fixed the problem for the GTX 1070 for a MSI GE73 Raider RGB 8RE.

Another post for the Valve Index which also shows that the problem is not limited to one headset:

You can't blame me if I think that what MSI support told you is wrong.

In that last post for the Valve Index, a workaround that has been discussed in other cases is to use a old nvidia driver that doesn't produce the fault like the 417.71 one. Mind you the latest drivers claim that they added support for the Cosmos so old driver might not work.

I appreciate your thoughts.  Upon calling MSI back, we tried various VBios to get it to work.  I can now say this headset IS WORKING.  Here's the fix.  Use latest Nvidia drivers, use Vbios 86.04.7D.00.37 (it must be that version!), flash system and reboot, use Vive Cosmos Beta software, and Mini DP 1.4 to Mini DP 1.4 cable.  Then system works as intended.  You must use that EXACT setup or headset will NOT WORK!.   


Thank you.

Edited by Tindelltech
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...