Jump to content

Error Code 215 During Setup, But Drivers ARE Updated


Recommended Posts

Nope. Still broken.

With the integrated graphics enabled it was initially detecting the vive as a upnp monitor and attempting to mirror/extend the display to the hmd. Enabling direct mode didn't fix this.

Disabling the integrated intel and nvidia chipsets worked in preventing it from being detected as a display, but then it gives me the "update your drivers" error code.

Pretty frustrating.

Link to comment
Share on other sites

Things I've tried:

1) validating that the mini displayport cable works (success)

2) Falling back to my 1080TI (failure)

3) using DDU 🙄 to remove and reinstall my AMD drivers (failure)

4) Reinstalling VIVE software via settings->troubleshooting->clear/reset

Clearly there is either a serious product defect OR someone at HTC didn't bother validating the driver compatibility. What's broken is somewhere between the displayport detection and the AMD driver. The USB/Audio/HID devices appear to all get detected appropriately, however the driver is doing a terrible job at working with Windows for device detection/configuration.

Firmware Version:

Cam/DP Version: 20190804/1604

RF Version: 3.15.1/3.15.1

AMD VII Driver: 19.12.3

Link to comment
Share on other sites

The driver for the Cosmos is defaulting to C:\Windows\System32\drivers\monitor.sys (Generic PnP Monitor). I don't care about this install, so I manually removed that and am re-running the Radeon driver installer; updated to follow. HTC should probably run an update to their error codes or include a link to a howto guide on changing the driver when the crufty Windows10 default driver gets picked as a default.

Link to comment
Share on other sites

Did get everything working; don't have a clear path to recovery, but I essentially reinstalled everything (AMD drivers and all) and then used steam to reset usb devices. Total time to get setup was probably >10 hours and at least 10 reboots.

  • Like 1
Link to comment
Share on other sites

  • 2 weeks later...

Been busy due to holidays, but finally got it working after a lot of troubleshooting. What finally fixed it for me was flashing my BIOS to the most recent (and beta) version.

I also switched my power supply to a more powerful one, as the one I had just barely matched the minimum requirements for my video card. However, I tried that before updating my BIOS and it still gave me the same error. So, I'm not sure if just the updated BIOS would have also worked with my old power supply.

  • Motherboard: MSI B350 Tomahawk
  • CPU: AMD Ryzen 5 2400G Processor with Radeon RX Vega 11 Graphics
  • Video Card:  ZOTAC GAMING GeForce RTX 2070 AMP Extreme 8GB GDDR6 (not a super)
  • Old PSU: Seasonic G Series 550 550W
  • New PSU: Seasonic G Series 650 650W


  • Like 2
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...