Jump to content
Happy Holidays! Limited Staff Responses: 1/20 - 1/31 ×

UE4 Can't packaging when 'for distribution' is checked.


luochuanyuewu
 Share

Recommended Posts

Hi, dear community.

i  can't packaging my project correctly when i check “for distribution” in my project settings.

here is my dev  environment:

  1. installed android sdk as normal (nothing wrongs here.)
  2.  ndk: 16b
  3. win10 pro 1903
  4. Unreal Engine 4.22.3
  5. Wave_3.1.4_unreal sdk.
  6. jdk: jdk1.8.0_77

here is the description of my problem:

I have successfully prepared the Android development environment according to the document description (I can guarantee that this part has no problems at all, because I can successfully package normal Android projects), but as long as I enable the wavevr plug-in in in the UE4 project and check "for distribution" in the packaging settings, I cannot package. The error comes from a library called "mockito". If I enable the wavevr plug-in and uncheck "for distribution", then I can package normally. I reproduced this problem in a blank project ( with wavesdk enabled), the sample project you provided, and our own project.

steps to reproduces:

1. Install Android SDK, NDK, JDK

2. Create a blank blueprint project and fill in the path of SDK, NDK and JDK in Android SDK under project settings.

image.png.cc728fe494f27de2446376b94b7a633e.png

3. Fill in the relevant information in the extra settings for < Application > section under advancedapkpackaging

image.png.836696c60d6d08d9773ca0aeae41d97c.png

4. Create a blank map called NewMap and save it under content.

image.png.e41d6be40bbcce8541012fbd312f6807.png

5. Copy the WVR folder to the engine path, and copy wavevr to plugins / wavevr under my project. At the same time, enable the wavesdk plug-in in UE4, and disable oculusvr and steamvr at the same time.

image.png.8a7bab4093062e5f03fba9fe067cdc7c.png

image.png.fd6b3fe0864342565d934452247a5042.png

image.png.5e606b66236971470f356b8094a2f6b7.png

image.png.5f5d54ecd04c596f8148bd7a7c7afd14.png

6. generate apk keystore and config it.

image.png.a20d7a3b567e403b529108e06e5516b7.png

image.png.ab48f0235e267e109be769bd0f04fe37.png

7. Check "for distribution" under packaging settings

8. Hit packaging.

image.png.d4ad85c65c8d44534244755b3f067f95.png

 

What i expected:

   The package should be successful and a signed APK should be generated

What i Got:

169720880_TIM20191213161055.thumb.png.4b8aa49b68f16724036f116f4497c656.png

1859428117_TIM20191213161230.thumb.png.71ecad0a2ccdc08cf8d5af40cca224cd.png

 

Conclusion:

It seems that this kind of error cannot be solved on my own. I hope you can check this problem. I have provided a complete log and a project that can reproduce this bug.

 

FullLog.txt

 

Thanks.

 

 

 

 

 

 

 

 

 

 

Edited by luochuanyuewu
Link to comment
Share on other sites

Hi @luochuanyuewu

We found it's conflicting to other tool installed on your build machine. Could be a false alarm. Suggest to try below quick fix to make it build pass.

  1. Find this file: <YourProject>/Plugins/WaveVR/Source/WaveVR/WaveVR_UPL.xml
  2. Add line 80
    80 -dontwarn org.mockito.**
    81 -dontwarn com.htc.vr.**

This should help you keep working on the project. We think it shouldn't be any impact disabling this warning for your case. Please let us know if it works for you.

Link to comment
Share on other sites

23 hours ago, Cotta said:

Hi @luochuanyuewu

We found it's conflicting to other tool installed on your build machine. Could be a false alarm. Suggest to try below quick fix to make it build pass.

  1. Find this file: <YourProject>/Plugins/WaveVR/Source/WaveVR/WaveVR_UPL.xml
  2. Add line 80
    80 -dontwarn org.mockito.**
    81 -dontwarn com.htc.vr.**

This should help you keep working on the project. We think it shouldn't be any impact disabling this warning for your case. Please let us know if it works for you.

Thank you very much! The problem has been solved

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...