Jump to content

Display Errors in Performance graph


Recommended Posts

I recently upgraded my computer's CPU to a Radeon9 3950x and have been getting a lot of pauses with the headset. It seems common or most noticeable when turning my head but the performance graph shows a lot of "display errors" (magenta bars) on the performance graph. Does anyone know what might be causing this or how to fix it? It didn't happen before the upgrade.  GPU is a 1080ti.


Link to comment
Share on other sites

I am having similar issues and came to the Vive forums to try to find an answer. I will experience stuttering very similar to how OP describes in just about every game and experience, despite the fact that, during play, my CPU, GPU and RAM are perfectly fine and not being overburdened. This is not your ordinary lag here. I'm on an original Vive, for the record. Attached are my PC specs, a screencap of what looks to be a very similar Performance Graph to OP and a video where I attempt to showcase the stuttering using an empty VRChat room and a lightweight avatar as the test subjects.

As for OP, did you try updating your lighthouses? It looks like they're due for some attention. That's the only advice I can offer.




Edited by SuperSonic68
Link to comment
Share on other sites

So I reformatted my computer and to my great displeasure, the issue still stands.

HOWEVER, I tinkered with vive settings and found the one option that appears to fix the issue entirely. Note: I haven't had the time to actually play a game since Im currently at work but the graph seems to show no magenta bars which are display errors. It does look like the magenta bars appear in the same frequency and pattern as the green spikes but I have no way of confirming that. If a person and Vive could look into this, that'd be great because I'd definitely like an explanation of what's going wrong here.


Anyway, the fix is to go to SteamVR Settings > Video > Per-application video settings > Set "Use Legacy Reprojection Mode " to On


Link to comment
Share on other sites

@Reimus Unfortunately this sounds very much like a PC-specific error as it survived the clean install. The HMD itself is basically a glorified display with sensors - they generally work or they don't work and aside from perhaps USB/DP bandwidth issues - I can't think of anything that would cause this behavior on the HMD side. You can try using older Nvidia drivers but there really isn't a ton of definitive steps beyond disabling motion smoothing and using legacy reprojection. If you Google the terms "motion smoothing, steamVR, and lag" you'll see alot of people reporting similar issues but unfortunately not alot of actionable steps to take.

Motion smoothing is a Valve technology - they may have additional info if you reach out to their support or post on the SteamVR forums.

Link to comment
Share on other sites

  • 4 months later...

Reimus & SuperSonic,

I was having a similar problem and there were two things that fix it for me, though I had that spike PLUS it was just dropping out for a 1/4 second, leaving a gap in the graph of about like this, (though I just Photoshopped yours)


First, and most important, I had to turn off MalwareBytes.  That immediately stopped the gaps.
Second, I got the spikes to go away by just moving the base stations a little farther apart.  I have the older one that only has 2 base stations, but I'm sure this still applies to yours.  1.) Your base stations must be able to see your helmet and 2.) Your base stations must be able to see each other.  I would add one more that's just an opinion, but if you have a lot of reflective surfaces like picture frames or like a glass door, it might help to test by covering those surfaces.  I'm just guessing here but I'd bet that the light houses have an error buffer that's getting filled up and that's something of a purge and soft restart.  I had to put something over a picture that hangs behind me and it improved performance.

Good luck!  Let us know if that makes a difference or if you've already tried it.


Link to comment
Share on other sites

  • 2 years later...

Good afternoon friends.

Faced the same problem. MSI GP66 Leopard 10UG Core i7 10750h RTX 3070 (130 Watts) It became difficult to play due to camera shake.
I tried all the tips from the posts above - it didn't help. After two days of experimentation, I found a solution for myself. Completely removed Nvidia Geforce Experience I mean, also removed the Game Ready drivers. After these actions, no friezes. Very smooth picture.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...