Jump to content
Happy Holidays! Limited Staff Responses: 1/20 - 1/31 ×

Very bad stuttering after sometimes hours of playing without issue


BloodSyphon
 Share

Recommended Posts

I know this is probably more SteamVR / Alyx, but I figured I would post here to see if anyone has any recommendations. 

I'm experiencing extreme stuttering playing Half-Life: Alyx on my Vive Pro and original Vive. I cannot reproduce it in any other game. Sometimes I can play for a solid hour or two without any issues, then out of nowhere I get extreme, nonstop stuttering. Other times I start experiencing it immediately after loading a save. I can sometimes cause it to happen by using the weapon switching HUD. As soon as I open the weapon switching screen, it's non-stop stuttering. Opening the steam overlay / settings menu ALWAYS causes this if I am running Alyx. The steam overlay / settings menu never causes this issue if it's another game running. Sometimes if I exit out of Alyx to VR Home, the problem will extend to VR Home and be choppy there as well. I can't reproduce it in VR Home if I haven't first played Alyx. If anyone has additional recommendations other than reinstalling Windows, I'd love to hear it. Thanks. 

GeForce GTX 980
MSI B450 TOMAHAWK MAX w/ latest firmware
AMD Ryzen 5 3600X
32 GB RAM
Windows 10 up-to-date
Vive Pro (and original Vive)
Original Vive controllers
1.0 basestations

The only thing that even remotely helps the issue is toggling async_mode_toggle (shift+a). When this is toggled off, the issue is almost completely eliminated, but if I lose a frame it jerks the screen pretty bad, and this happens freqently enough to make me not want to play like this. Seems like I really need this feature to be on. 


Here's some things I've tried that did not help:

  • Plugged in my original Vive using the HDMI port, and experienced the same issues. Doesn't appear to be specific to the Vive Pro HMD. 
  • Reseated every cable multiple times
  • Tried different USB ports
  • Tried a different port on my video card
  • Tried current Nvidia drivers, 445.75, as well as a few older ones (419.17, 397.93)
  • Completely removed Nvidia drivers with a 3rd party video card driver cleaner and clean installed
  • Updated all drivers using Snappy Driver Installer
  • Removed all SteamVR config files and completely uninstalled and reinstalled SteamVR
  • Set PC to 'High performance'
  • Set NVIDIA power management to Prefer maximum performance
  • Set SteamVR to disable power management
  • MSI motherboard but I've never installed afterburner
  • No hardware monitoring software installed
  • No overclocking software installed
  • System is not overclocked in any way
  • Removed Avast antivirus as it was on the conflicting software list 
  • Disabled Windows Defender
  • No other software installed that is listed on the conflicting software for SteamVR
  • SteamVR motion smoothing on and off
  • Graphics and texture sizes set to lowest option
  • Tried SteamVR beta

 

Here's a few examples of what this looks like from the frame timing window:

1088557040_whatevenisthis.thumb.png.b53258c16ecff51b668923265e5e06bc.png

 

jesus christ.png

Edited by BloodSyphon
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...