Jump to content
Happy Holidays! Limited Staff Responses: 1/20 - 1/31 ×

Cosmos Elite: very poor image quality with wireless


Recommended Posts

Last week I received my Vive Cosmos Elite complete package: headset, controllers, base stations, wireless adapter + kit.
I tried a little without wireless, and after that I followed the instructions to install the wireless adapter.

I have been playing a little with the wireless adapter. The image quality is very poor. It looks very pixelated, like with a very low resolution. My first thought is that the connection is not very good, but it happens even when I am standing 3 meters right in front of the receiver (or whatever that is) connected to my computer.

I don't know what the problem is. With the cable it looks pretty good, but with the wireless I didn't have a chance to get a decent picture.

Any idea?

Link to comment
Share on other sites

Hi @troublemaker_na,

Apologies on the issue you're experiencing. We'll get to the bottom of this. We'll need a couple more information from you to identify the cause.

  • Could you share us your computer specs?
  • Could you provide us where you've inserted the PCIe card in relation to your GPU? Are they next to each other?   
  • Please submit an issue report and tag rd_issue_log . Once submitted, please provide us your Trace No.
    • Here are instructions to do this: 

 

Link to comment
Share on other sites

Hi guys, thanks for the answers. I have been playing a bit, and things are a bit strange.

First thing, my specs:

1) Processor: AMD Ryzen 7 2700X

2) Motherboard: ASRock X470 Taichi Ultimate

3) RAM: 64 GB  @2866. I didn't want to pull a module out to look at brand and model, but if needed I can do it.

3) Video card: Gigabyte Aorus GeForce GTX 1080 Ti Xtreme Edition

4) Hard disk: Samsung 960 Pro NVMe 1TB

6) Power supply: Corsair AX760

That said, yesterday I could kind of play (Half Life), although with some flickering. Today I just had continuous disconnections; displays in the headset were turning blue, white, black. I mostly only had audio. The computer was continuously sounding like when a new device is plugged in. Yesterday it didn't look nearly as bad, although it did a couple of days ago.

So i removed the wireless and I started with the cable. Started Half Life, no problems at all.

I didn't really play, but there was no flickering. Image stable, everything looked good. CPU was stable at about 30%, GPU at 70%.

It must be something with wireless.

As to where the card is inserted, it's a few centimeters (about 3) from the video card. For a better idea, looking at the drawing of the motherboard from the Quick Installation Guide (on the 4th page):

https://download.asrock.com/Manual/QIG/X470 Taichi Ultimate_multiQIG.pdf

The slot PCIE1 is for the video card, which covers PCIE2 and it almost reaches the level of PCIE3. The card is inserted in PCIE4.

 

In the coming days I will create an issue, but if it would be nice if someone could come up with an idea before I do that. Issue tickets tend to be quite expensive for everybody, and often don't come to a solution.

 

Many thanks.

 

 

Link to comment
Share on other sites

Okay, I wasn't planning on upgrading my machine at the moment. Before I spend some more money, can I know what the reason is? What is the difference between wireless and no wireless?

I tried with wireless again, and The CPU doesn't go above 50%. The GPU, on the other side, has sometimes peaks of 100%. Why is that? I didn't see that when I used the cable.

 

Oh yes, the hyperthreading thing. I couldn't find it in the BIOS. I am starting to wonder if the motherboard has it in the first place; I am honestly surprised i couldn't find it. Also in the manual there is no mention of it:

https://download.asrock.com/Manual/X470%20Taichi%20Ultimate.pdf

I tried shortly to boost the priority, I didn't see any difference. After that I didn't look at it anymore, because the CPU usage was actually quite low, as I said. I will try again.

Link to comment
Share on other sites

@Beta_Tester even you would probably get better wireless performance with a better/faster cpu imho.  Trouble with wireless comparisons is that they are often tainted by what games/apps/sims people are using because some utilize multi cores better than tohers.  Probably no size fits all.  However, in all cases the best/fastest cpu together with the best gpu and fast ram will always win ( together with good cooling and a good power supply).  One thing I found with wireless is that it does not like overclocked gpu's and their associated software like afterburner.

Link to comment
Share on other sites

Ah, very interesting, thank you.

In the meanwhile I found something.

That 100% peak in the GPU usage got me thinking. So i checked the driver version, and the version I had, installed by Windows, was much lower than the latest currently available from Nvidia on their site.

So I disabled the stupid Windows automatic driver update, I uninstalled my older version (just to be sure), and I installed the new one that I downloaded from Nvidia.

The installation failed.

So I did some research, and I found out that I only had 2 GB left on my 1 TB hard disk. I use that hard disk only for games. Go figure.

So I made some space, got more than 60 GB, and I installed the Nvidia driver.

Well, now it's working pretty good. I am in Europe, so now it's 3:20 AM. I played for some minutes, but now I am going to sleep. I will try again tomorrow.

But, at least so far, it looks like the problem was the Nvidia driver, or maybe not enough space on the hard disk (shouldn't I get some error in that case?).

I consider the problem solved for the moment. Hopefully now it's time to play :-)

 

Thanks a lot guys.

  • Like 1
  • Thanks 1
Link to comment
Share on other sites

13 minutes ago, Beta_Tester said:

Excellent. Glad to hear you got it working - even if your sleep might suffer! Do you know if SMT is enabled on your setup at the moment? I might try re-enabling it on mine if you aren't having issues.

SMT or Hyper threading off should not have much impact with current win10 versions/updates imho..

Link to comment
Share on other sites

hey, sorry if I didn't reply, but I wanted to take some more days to look at the issue, because there have been some developments.

What happened is that the headset worked one morning, and in the evening the issue was back.

So, because SteamVR was keeping searching for the headset, I wondered what would happen if I just started the Vive console. I really thought that I tried to start the console only before, and I had a message saying that SteamVR was not running, or Steam was not running, or something like that. So I was expecting that to happen again.

Instead, I started the console, I put the headset on, I tried to start a game, and the game started.

In the past 4 days I have been playing without problems, except once when I moved a base station and I redefined the play area (I was having rubber banding issues). But restarting everything solved the problem.

I still have to try to start again Steam(VR) first and the console second, so I am not sure if that really was the solution of the problem. But at least now I can say with some confidence that the problem is gone.

I do still have some rubber banding, but at least I can play :-)

Concerning SMT, what is really not clear to me is how that can solve the problem is the CPU usage doesn't reach 100% in at least one core, unless it's triggering some bugs if it's on. I wouldn't expect that to be the solution.

  • Thanks 1
Link to comment
Share on other sites

  • 2 weeks later...

Hard to believe, but I spoke too soon. Screen still turning blue and/or white, and then black. Looks like the headset restarts. Also seeing things jumping all over; the impression is that there are tracking problems. Don't know how that could happen, to be honest.

Other solutions that I have tried:

Still having issues. It worked kind of decently for days, and the past couple of days the problem is back in full vengeance.

I am close to giving up. I reported an issue. The trace number is 20200426105047

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...