Jump to content

Vive Setup application keeps crashing


Recommended Posts

Hello to whomever is reading this,

I recently got a Vive Cosmo Elite & was excited to try it out, only for my excitement to quickly sour when I attempted to run the setup.exe installer and it doesn't install. It will open, then says "Checking versions" followed by "Preparing" then once the light blue bar reaches the end the installer crashes and installs nothing. I've been wrestling with this issue for days now, combing through the forums of Vive, Reddit and Steam to seek any & all troubleshooting steps to resolve the issue. I've deleted residual files that the installer left and attempt to install again to no avail. In one instance I've discovered the installer.exe application amongst the files and decided to run, to make something happened and it managed to install VIVEport. It was a step... a side step in my opinion. Then I attempted to install the setup through viveport and behold... the same result It crashed. I've sook help from the vive support team. Their response time (for me) took like 16+ hours but that's because they're in a different time zone so... I can't blame them nor will I for this.  When I explained my ordeal to them I was provided 2 troubleshooting steps that in my opinion are one of the same. These were to delete any and all files and folders involving vive software (which were done) To manually open the setup file in the following file path   C:\program files (x86)\VIVE\Updater\App\Launchers   while turning off the firewall. For me, this file path did not exist for the software was never installed so I made the file path and again not avail. In waiting for a reply I combed through those files again & found the setupinstaller.exe and decided to run it because at this point I was like (FAQ it) and received an error message saying that it was missing a few dll files. Next reply from support and it was a series of questions 1) Are you using a home network; Ans Yes. 2) Do you have another computer that you can download and install the setup; Ans No I do not. 3) Do you Have another network to try; Ans No I do not. I reported my findings to the support team in that response and offered a report from the vive folders that shows the crash. Next reply was a step, to delete the vive files (which can be found in this file path { C:\Users\User Name\AppData\Local\Temp (%USERPROFILE%\AppData\Local\Temp) }) and uninstall steam and viveport. .....Steam?? why steam, what does steam have to do with this. Is what I thought so I decided to go forward with it because support provided it as a step. I painfully uninstalled steam and uninstalled viveport and made sure firewall was off, deleted any & all files that was associated with vive and manually opened the setup.exe in the previous file path.... nothing... no change... no progress. I decided to look and event viewer to see if I can get some more information on why this is happening,  I discovered a Application error event that shows the following below.  I came to the conclusion that it might be a corrupted install but even so I deleted all the files and try to install but the same keeps happening. So I decided to try an program I have on my PC called  Restoro. a repair software that can restore and replace DLL files, perhaps it can restore the install, nothing worked so (FAQ it) I ran the program. Nothing same results... heart broken. Now these has been a lengthy forum message but do not misunderstand, its not a rant, yes I'm upset that I finally got a vive headset and I'm unable to use the thing and now I have to take it but I want whomever is reading this take something from my experience. Some steps that you can try if you're experiencing the same because you never know if one of these steps that failed me can success for whomever. A thread that provide some ideas on how to go by resolving this issue and if you got some steps of your own that you didn't see here, drop it in the thread. Build it up and make a thread that some could go to and find helpful information and not some stranger ranting and cursing the product without providing some steps, because that doesn't help anyone. Good luck to those who are experiencing this issue and hopefully this was helpful in some way and good day to you all. 


Log Name:      Application
Source:        Application Error
Date:          12/6/2020 11:59:52 AM
Event ID:      1000
Task Category: (100)
Level:         Error
Keywords:      Classic
User:          N/A
Computer:      DESKTOP-000000
Faulting application name: ViveCosmosInstall.exe, version:, time stamp: 0x5e428288
Faulting module name: ntdll.dll, version: 10.0.19041.662, time stamp: 0x5f641e44
Exception code: 0xc0000005
Fault offset: 0x000468ee
Faulting process id: 0x3300
Faulting application start time: 0x01d6cc0a5bd94d42
Faulting application path: C:\Users\qwerty~1\AppData\Local\Temp\ViveCosmosInstall.\ViveCosmosInstall.exe
Faulting module path: C:\WINDOWS\SYSTEM32\ntdll.dll
Report Id: c9e7ba37-6f31-446d-a73e-e20f9f5bd6fd
Faulting package full name: 
Faulting package-relative application ID: 
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
    <Provider Name="Application Error" />
    <EventID Qualifiers="0">1000</EventID>
    <TimeCreated SystemTime="2020-12-06T19:59:52.0632062Z" />
    <Correlation />
    <Execution ProcessID="0" ThreadID="0" />
    <Security />


Link to comment
Share on other sites

  • 5 months later...

I have the same problem bro, the installer crashes during the preparation stage. I installed the software on 4 computers, the software does not work on two, but it works on two, but this is a laptop that does not support VR. VIVE ANSWER us !!!!

Link to comment
Share on other sites

We do support laptop. what's the crashes msg? sometimes it may related to the windows version, language or media pack, or so. 
If you still require assist on the installation, feel free to send me PM.


Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...