Jump to content

I cannot complete SRWorks Unity Plugin.


Recommended Posts

Hi, I am using Unity to develop.

To start Vive SRWorks SDK I have followed the following steps instructed by “Quick start for SRWorks Unity plugin.”

Step 1. Complete the environment settings and then launch unity engine

Step 2. Import “Vive-SRWorks-Unity-Plugin.unitypackage”

Step 3. Restart unity engine

Step 4. Open the sample scene located in ViveSR\Scenes\Sample

SRWorks Runtime is running successfully as I see the notification and icon. SteamVR and HMD are also on. 

However I am unable to accept the settings as shown in Step 5.  The first page of the three pages appears but I am not able to proceed to the second page by hitting “Accept” (the page does not change). 

I did not import SteamVR Unity Plugin (current version 2.6.1 (sdk 1.13.10)) as the above steps do not include this importation.  Is this correct?

I also tried the same procedures by adding the import of SteamVR Unity Plugin prior to Step 2.  However this did not work either and I had the same problem in Step 5.

 The following are my environment settings. 

Vive SRWorks Version:

 SteamVR Version: 1.15.15

 Unity Version: 2020.2.0f1

 VR device: VIVE Pro

 I would appreciate your support to solve this problem. @Corvus @Tony PH Lin

Link to comment
Share on other sites

  • 4 weeks later...

For me the next steps worked well:

1. Import SRWorks package into Unity Project

2. Reload Unity

3. Download SteamVR package(I have loaded it after the SRWorks package to avoid problems with the input action file)

4. Download SRWorks Expirience package(optional)



Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...