Jump to content

Need help with Vive COSMOS!


Recommended Posts

I just bought a Vive Cosmos yesterday as a first time VR user.

I went throught the setup process and everything went fine. Setup was a success. I went through the process where it scans your room; however SteamVR wouldn't see the headset so I decided to uninstall the Vive components and run the setup again. However, the setup started to give me an error saying I needed to connect the converter into a USB 3.0 port or higher. But it was already connected to a 3.0 and I checked and saw that the 3.0 port and its connection were working just fine.

I reinstalled all the Vive stuff, Steam, SteamVR and even wiped all of my disks and reinstalled Windows 10. I tried updating USB drivers, reinstalling USB drivers and everything else I could find on the internet. None of it worked, until I opted into Steam's BETA and ran steam as admin.

That helped it function (sort of). I got the green light on the LED and it was working. But, while SteamVR was recognizing the headset, Vive Console wasn't. It was stuck on "turning on" and was giving different errors each time saying the headset wasn't connected. But I could at least get it to kinda work if I opened SteamVR before Vive.

Well today I decided to reinstall everything again hoping that I could solve the issue. It didn't work.

It deleted the room scan thing so I don't even have the VR area (the highlighted circle in my room that I can see with the headset is on). That made it so that whenever I use the headset, all I see is dark gray everywhere (however it is turned on and led is green) and when I press the Vive button on the right controller, it brings up the Vive menu; but my controllers don't work otherwise so I can't actually do anything in the menu either. And oh, also, the Room Setup doesn't work AT ALL. It crashes everytime I open it with the headset connected (and when I open it without having the headset connected it does load up, but when I launch the Vive Console and have the headset connected, the Room Setup won't recognize the device). SteamVR Room Setup doesn't work either, same issue as the Vive Room Setup app.

Having that issue I just decided to do ANOTHER reinstall; and am now back at step 1. The setup says that I need a USB 3.0 or above, and won't work (It is indeed connected to 3.0 and worked fine the first time I ran the setup!!!!). I was somehow able to work around this issue before but have no clue as to how I did it, so I couldn't fix it again. Now I can't even use the headset at all. (When I did get it to work the setup was still giving that error about the USB but it worked nonetheless)


Fixes I have tried:

Making sure both my monitor and the Cosmos are connected to the correct GPU display port (I use DP for my monitor as well)

Reinstalling all Vive apps/Steam/SteamVR/Windows 10.

Reinstalling USB drivers, checking updates for drivers.

Opting in and out of Vive/Steam/SteamVR betas.

Deleting connected USB drivers from SteamVR developer settings.

Resetting the headset from Vive Console.

Enabling and disabling Direct Mode in SteamVR.

Making sure that the USB 3.0 ports are ACTUALLY working.

Resetting the linkbox (converter) to have Windows reinstall the Cosmos drivers.


Edited by Gus
Link to comment
Share on other sites

SUMMARY: Vive and SteamVR Room Setup apps don't work, are unresponsive and crash. I had a lot of issues since I got the Cosmos; I was able to work around some of them; but I keep having the same issues and can't solve them. Cosmos Setup keeps saying I need to connect it to USB 3.0 or higher but it already is, and it worked just fine without giving any such error when I initially set up my Cosmos. Now I can't use the headset at all and the fixes I've tried are above.

I'm on Win10 with i7 7700; GTX 1060; And a Samsung monitor using DP.


This is a huge annoyance considering I decided to pay almost 50% more for this device instead of the Oculus.

Edited by Gus
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...