Jump to content
Happy Holidays! Limited Staff Responses: 1/20 - 1/31 ×

Wave Unity SDK - DirectPreview not working - Install Device APK fails


sapschrott
 Share

Recommended Posts

Dear Ladies and Gentlemen,

i try to get Direct Preview with your Wave Unity Legacy SDK Version 3.2.0 running on a HTC Vive Focus Plus.

I followed your guide regarding setup and installation: https://hub.vive.com/storage/app/doc/en-us/wavevr_DirectPreview.html

But the "Install Device APK" fails already. I have connected the Focus via USB to the machine and defined this aswell in the Direct Preview Options.

grafik.png.642a9cd7a6023ede57f2f9fa1524d384.png

Android SDK has been installed and the System Path Environment Variable has been set.
I can also find with adb devices via cmd the VR headset

grafik.png.218da8f596e808eba4cae379461d5d0e.png

I am using Unity version: 2019.4.25f1

Can you help me?

Link to comment
Share on other sites

Hi chengnay,
 

yes that is the only device which is listed when i call adb devices.

Before I enabled Developer Mode and USB Debugging in the HTC Vive Focus Plus there where no devices found.

Wifi doesn't work either.

As in the logs written it tries to write to an sdcard? However i can find the desired path ("sdcard/Direct/Preview") on the htc focus device
Does DirectPreview only works with an SDCard in the HTC Vive Focus Plus? Or is the internal storage not get used for that?

Link to comment
Share on other sites

Hi @sapschrott,

We just found that installing apk through Unity menu fails occasionally.

We suggested that you could install the apk manually.

 “adb install” wvr_plugins_directpreview_agent_unity.apk located at “ Assets\WaveVR\Platform\Windows .”

 

And we’ll keep working on clarifying this situation.

Link to comment
Share on other sites

Hi @Tony PH Lin

thank you for your response.
This workaround worked for usb connection worked.

However i can't get wifi connection running

The IP adress is correct, i can reach the device via ping on cmd

If I run "Install Device APK" from Unity with Wifi Connection enabled, the opened command line logs out:

- waiting for device -

Obviously i don't get a device with "adb devices" shown.

adb connect 192.168.178.43:5555 didn't helped.

"cannot connect to 192.168.178.43:5555: No connection could be made because the target machine actively refused it. (10061)"

 

Link to comment
Share on other sites

  • 1 month later...
  • 1 month later...
On 7/2/2021 at 5:59 AM, Tony PH Lin said:

Yes, please be noted to install adb.exe in the root directory so the command can be executed succesfully.

Thanks.

What root directory are you referring to? Unity Hub installs it into

C:\Program Files\Unity\Hub\Editor\2020.3.16f1\Editor\Data\PlaybackEngines\AndroidPlayer\SDK\platform-tools

Got the same problems as described above. Environment variable is set, but installing the apk fails with the same message. I do not need the SD card to do this, do I?

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...