Jump to content

Vive hand tracking 0.10.0 Samples not working


Recommended Posts


I am attempting to run the samples provided in the 0.10.0 VIVE Hand Tracking SDK on my HTC Vive Focus Plus. Unfortunately, I get compilation errors saying that

Assets\ViveHandTracking\Sample\Scripts\DisableController.cs(16,7): error CS0619: 'Interop.WVR_SetInteractionMode(WVR_InteractionMode)' is obsolete: 'This is an obsolete function.'

I also tried the 0.9.4 SDK but I get errors saying that namespaces are missing.

I have used:  

- Unity 2020.3.11f1

- Wave SDK 4.0.0

I looked at release notes and it said that WVR_SetInteractionMode was removed. If this is the case, how do I get the samples working? 


Thanks in advance!!

Link to comment
Share on other sites

Hi @atea

Wave SDK 4.0.0 is currently not supported by hand tracking SDK yet. We plan to add support in next release.

For now, you can use Wave SDK 1.0.1. You can goto package manager, find all wave package, click 'other versions', and select to install previous versions. Please make sure to install same version for all the 3 Wave packages.

  • Like 1
Link to comment
Share on other sites

Thank you for the prompt reply!!

After downgrading to 1.0.1, I get the following error (even after starting a new unity project):

Library\PackageCache\com.htc.upm.wave.xrsdk@1.0.1\Editor\WaveXRPlayerSettingsConfigDialog.cs(95,18): error CS0117: 'PlayerSettings' does not contain a definition for 'SetVirtualRealitySDKs'


More details:
I am still using Unity 2020.3.11f1.

Just for reference (i dont know if this is relevant), I cannot find SetVirtualRealitySDKs in the Project Settings > Player menu.

For the fresh project, I just created a new project in unity and tried adding the 1.0.1 wave xr library and that error popped up.

Thanks in advance!

Edited by atea
More details
Link to comment
Share on other sites

Hi @atea

OK, I think this is incompatibility between Unity 2020 and WaveXR 1.0.1.

If you can downgrade to Unity 2019.4, I would suggest to use LTS version.

Otherwise, you might need to manually remove the `SetVirtualRealitySDKs` part in the code.

  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...