Jump to content

Setup Vive Pro 2 on Linux


Recommended Posts

I recently purchased an HTC Vive Pro 2, hoping I could use it to enhance my software development environment, on Linux (distro: Pop!_OS, an ubuntu with better nvidia support out of the box. You can treat it as ubuntu). I do not own or want a windows machine, I refuse to run my development environment in a windows VM, please only provide solutions for linux.

I couldn't find any resources online as to whether the Pro 2 would work on linux, but I also couldn't find any resources saying that it couldn't be done. I hope this thread can clarify that for any other adventurous souls, once the solutions come in.

Here are some SOLVED issues I came across on the way:
1. when installing the setup software from https://www.vive.com/eu/setup/vivepro2/ (for which you don't need the vive pro 2 hardware), and running it with `wine` (64-bit, 5.0.3), it requested that .NET 4.6 or newer is installed. The shortcut button didn't work, but you can follow the automatic installation instructions here: https://appdb.winehq.org/objectManager.php?sClass=version&iId=32828 . `dotnet46` did not manage to install that way for me either, but `dotnet48` worked. It will give you some scary error/warning messages, but it will work. From now on, I use `env WINEPREFIX=$HOME/winedotnet wine VivePro2Setup.exe`, and it gets past that .NET requirement
2. it suggests that I upgrade my nvidia drivers for a better experience. I just skipped that, hopefully it won't come back to bite me later. It doesn't matter for now, because I've encountered more problems
3. it fails to install Steam automatically, but the blue bar at the bottom seems to process everything else correctly. The error message looks something like "Couldn't open Steam". Quit the setup, and you should see a new `Steam.desktop` file in your `~/Desktop`. Run the command it refers to, make sure it has the `$HOME/winedotnet` prefix, and it should install steam with updates automatically. It will also install 2 SteamVR items. I waited for them to be finished, then went through the vive setup program again. Now if you wait a few seconds before clicking "INSTALL" when it wants to install VIVE and Steam, it will determine that you already have them installed, and will give you a "SKIP" button

Where I'm at (UNSOLVED):
4. clicking that "SKIP" button from step 3 seems to just quit the setup, with no clearly associated error message. I did find `wine: Read access denied for device L"\\??\\Z:\\", FS volume label and serial are not available.` in the logs, but I'm not sure that's related, it showed up well before pressing the button. The only other option on that screen is the "UPDATE" button, but that leads to the same error as step 3. After the setup quits from "SKIP", wine is still running, and I get occasional logs in the terminal, that look like `01f9:err:ole:CoUninitialize Mismatched CoUninitialize` and `005a:err:ole:ifproxy_release_public_refs IRemUnknown_RemRelease failed with error 0x800706be`

Edited by towc
Link to comment
Share on other sites

A community pointed out that if I want to use this with SteamVR, I probably don't need the setup application at all. So I installed SteamVR through Steam, without wine, plugged the cables in, and was met with this dialog: Image

So it seems that might be all, and I need to return the headset in exchange for something else

Link to comment
Share on other sites

  • 1 month later...

Vive Pro 2 only supports Windows. I believe you can use the OG Vive, and Vive Pro 1 on Linux via SteamVR's linux branch, but all other PCVR Vive Headsets are Windows only (Pro 2, Cosmos, Cosmos Elite, Focus 3 via Vive Business Streaming).

There is not a linux distro of the required middlewear Vive Console, and it is not currently on the roadmap due to request for linux support being fairly niche.

@davide445 @towc

Link to comment
Share on other sites

My question due the OP seems to have solved most of the problems, I know there is no official support.

At this stage I will probably need to go trough Valve Index path as the only one supporting officially Linux. Not my preferred choice for a corporate project in the medical sector.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...