Jump to content
Happy Holidays! Limited Staff Responses: 1/20 - 1/31 ×

Problem tracking controllers in UE4 using Business Streaming and StearmVR.


vito0719
 Share

Recommended Posts

I created a UE4 project with VR template, set up my Focus 3 using Business Streaming (USB), and play in VR Preview.

And the virtual hands won't follow my controllers. They'd just stay where they were spawned.

 

I didn't encounter anything like this about a month ago.

I tried the same project Oculus Quest 2 using SteamVR and the hands tracked fine.

I tried to play a VR game (Beat Saber) with my Focus 3 Business Streaming and the sabers also tracked fine.

 

After further digging, the root of the problem is this:

spacer.png

1. Every time I open a UE4 project with SteamVR enabled, the error in the above image pops up in my HMD. When I tried to configure the action manifest referenced in the popup window, the "Virtual Reality BP Game..." doesn't respond to my click at all, while all other apps can be configured properly. Meanwhile the popup also blocks the manifest file's path.

For this reason, please provide a generic file path and input binding file.

spacer.png

2. UE4 has an option to set up controller bindings. Even though I open it and set it up, the controllers in the project still don't follow the movement of my Focus 3 controllers.

So there's also this possibility: Is there a conflict between Vive Focus 3's new firmware and SteamVR's controller binding system?

(the "pair controller" in SteamVR is always initialising, but the "update device" recognizes my controllers just fine)

Or maybe a compatibility issue with UE4?

 

Oddly though, I was able to get it working after doing a factory reset on my headset. But it worked just once. Next time I tried the same problem happened again.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...