Jump to content
Happy Holidays! Limited Staff Responses: 1/20 - 1/31 ×

Unreal Engine Application installs as 2D app on Focus 3 and not A VR app.


KieranLatham
 Share

Recommended Posts

Hi all,

As the title suggests, I am having difficulties with the Focus 3 not recognising an application packaged in Unreal Engine 4 as a VR app and forcing it to install as a 2D app.

I have followed many tutorials on setting up for android and Vr development, checked the xml configuration per wave sdk documentation and added the extra tags, and had no luck in deploying as a vr app to the headset.

The application i am testng is the vr motion controller template.

Has anybody else had an issue like this or have any idea what I can do to make it launch as VR?

Cheers,

Kieran.

Link to comment
Share on other sites

Hi @KieranLatham,

Please make sure you have Start in VR selected. StartInVR.png.61518127133eca0b4b0079c4bbe5ece3.png

You will also need the WaveSDK plugin in order to build content for Focus 3. You can download the latest Wave SDK here https://developer.vive.com/resources/vive-wave/download/latest/

In case you already did this Make sure VIVE Wave™ is the only VR plugin enabled. Turn off all other VR plugins (especially OculusVR and SteamVR) to prevent conflicts.

I would also recommend you check our Unreal Engine Getting Started Guide.

Link to comment
Share on other sites

1 hour ago, Mark Moukarzel said:

Hi @KieranLatham,

Please make sure you have Start in VR selected. StartInVR.png.61518127133eca0b4b0079c4bbe5ece3.png

You will also need the WaveSDK plugin in order to build content for Focus 3. You can download the latest Wave SDK here https://developer.vive.com/resources/vive-wave/download/latest/

In case you already did this Make sure VIVE Wave™ is the only VR plugin enabled. Turn off all other VR plugins (especially OculusVR and SteamVR) to prevent conflicts.

I would also recommend you check our Unreal Engine Getting Started Guide.

Sorted, SteamVR hadn't switched off correctly (not sure why) but i disabled it and double checked the project settings and it's sorted now

  • Like 1
Link to comment
Share on other sites

  • 1 month later...
On 4/11/2022 at 6:42 PM, Mark Moukarzel said:

Hi @KieranLatham,

Please make sure you have Start in VR selected. StartInVR.png.61518127133eca0b4b0079c4bbe5ece3.png

You will also need the WaveSDK plugin in order to build content for Focus 3. You can download the latest Wave SDK here https://developer.vive.com/resources/vive-wave/download/latest/

In case you already did this Make sure VIVE Wave™ is the only VR plugin enabled. Turn off all other VR plugins (especially OculusVR and SteamVR) to prevent conflicts.

I would also recommend you check our Unreal Engine Getting Started Guide.

The SteamVR software hadn't been properly switched off (I'm not sure why), but I uninstalled it and double-checked the project settings, and now everything's fine.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...