Jump to content

I think my Vive's HDMI port might be broken. Looking for second opinions.


Recommended Posts

I've done a whole lot of testing to narrow down the possible problem. Here's a little background, what's wrong, what I've tested, and my supposition (I'll try to be brief):

Backstory: I'd owned the headset for a couple months without problems until several days ago it stopped working.



The Problem: The headset's screen is never (I mean never) on, but the Display Mirror does show that proper tracking in a working scene does occur, albeit only briefly. SteamVR produces a consistent series of problems; here they are:

    - 0. (Note that the headset screen never turns on during any of this, and the headset's LED is always solid red.)
    - 1. Upon launching SteamVR the program works as expected. The Headset Icon and both Lighthouse Icons are fully green. During this brief time the Display Mirror shows tracking working properly in a scene. The only thing not working is the headset screen; buckle in.
    - 2. After about twenty seconds of this the headset icon starts to flash solid green, the standard "Headset not tracking" message appears. ("This headset is connected but not tracking. Make sure it can see a base station.")
    - 3. The Display Mirror stops tracking. Both Lighthouse Icons change from green to grey, and the Headset Icon changes to a green outline. The Display Mirror changes from a scene to solid grey. Both of the actual lighthouses, not the icons, remain on.



The Testing: At that point I figured, "Probably a tracking issue. You know, on account of the tracking issue message." But let us temporarily fast-forward past all the logical attempted fixes to the one peculiar fix/problem I found that leads me to suppose the Headset's HDMI port is faulty:
    - 0. If I let the consistent series of problems occur from SteamVR, until I'm right back in the same state as described above in step three, and then unplug the HDMI cable from the headset. What happens? Suddenly the tracking works again, the error message disappears, and the Headset and both Lighthouse Icons are fully green. And this doesn't stop working in 20 seconds, it's stable. Once the HDMI is plugged backed into the headset, nothing will have appeared to change: screen is still off, headset LED is still red, but in twenty seconds the exact same series of problems from above will occur. Unplug the HDMI again, and tracking is working again. Screen never works though.



All the Other Testing:
    - 0. Tried the standards: restarting, unplugging, and connection-checking.
    - 1. Tried using the Headset on two separate, already-working Windows 10 installs. (That's what made me suppose hardware fault over software.)
    - 2. Tried replacing the HDMI cable between the PC and Linkbox.
    - 3. Tried switching between the GPU's HDMI ports.
    - 4. Tried connecting the Headset directly to multiple GPU ports.
    - 5. Tried replacing the 3-in-1 cable.
    - 6. Tried replacing the Linkbox.
    - 7. Tried unplugging everything, and selecting the "Remove all SteamVR USB Devices", then uninstalling SteamVR, then uninstalling Steam, then fully updating Windows 10 and my GPU driver, and finally reinstalling Steam and SteamVR.


If you read any of this, I appreciate you, and thank you for any support.

Link to comment
Share on other sites

Hi , 


There is definitely a chance that your display hardware itself is damaged or malfunctioning based on what you've described. You've run through virtually every troubleshooting scenario I'd recommend except perhaps trying the HMD on a second computer to verify that it's not your PC/GPU causing the issue. By replacing the 3-in-1 you've eliminated a root cause for many similar issues... 


At this point my best recommendation is to request an RMA from the live chat support here  (not the email us form) and tell them that the forum staff said that an RMA was in order. We just opened a new repair center so the turnaround time shouldn't be too bad. 

Link to comment
Share on other sites

I had very similar when viveport was installed.  I had to uninstall every single items in add remove programs (5 or 6 different vive related items).  I also had very similar when I would use steam VR and then beta version and switch back and forth between the two.


Curious have you tested without a linkbox at all, plug the hdmi directly into the headset from the gpu?

Link to comment
Share on other sites

  • 2 years later...

Ok this is stranger then fiction lol. But it worked. I went to device manager uninstalled my 3.0 usb drivers scanned for hardware changes it automatically reinstalled them. But heres the strange part I now get a 009 error connect to usb 3 or higher port in vive console that does not go away. But in the steam console headset found controllers found and base stations working. And games work perfect


Link to comment
Share on other sites

Update my vr is still working with above fix . Still have 009 error connect to usb 3 or higher port in vive console. But played all nite no problem. I have not been able to use more then 5 min for the last month. hope this helps the Developers narrow down the problemUntitled.thumb.png.ad733d4fa289acb1297c0efa77fa4e0a.png down the problem

Edited by roadrunner38b
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...