Jump to content
Happy Holidays! Limited Staff Responses: 1/20 - 1/31 ×

Remove controller connection popup on smartphone


GiulioZ94
 Share

Recommended Posts

Hi  Giulio,

 

I'm not sure what you mean by applications built on smartphone, but if you have an application working on the VIVE Focus, adding to the Android manifest the following line works:

...

<meta-data android:name="no_controller_pairing" android:value="true" />

</activity>
</application>

 

If you meant on a phone simulator, if it's not working I'm not sure if it can be disabled at this time but it's something we can look into.

 

 

 

 

Link to comment
Share on other sites

Hi. 

 

I tried exactly that on my Unity project. I added the meta-data node on the AndroidManifest.xml that comes with Wave SDK on the Plugins folder, but still my Vive Focus prompts me to pair my controller when the application starts. 

This is the exported Gradle project's AndroidManifest.xml:

<?xml version="1.0" encoding="utf-8"?><manifest xmlns:android="http://schemas.android.com/apk/res/android" package="com.CREAT3D.CyberVat" xmlns:tools="http://schemas.android.com/tools" android:installLocation="preferExternal">  <application android:label="@string/app_name" android:theme="@style/Theme.WaveVR.Loading" android:resizeableActivity="false" tools:replace="android:theme" android:isGame="true" android:banner="@drawable/app_banner" android:icon="@mipmap/app_icon">    <!--You can use your theme here.-->    <activity android:name="com.htc.vr.unity.WVRUnityVRActivity" android:label="@string/app_name" android:enableVrMode="@string/wvr_vr_mode_component" android:screenOrientation="landscape" android:launchMode="singleTask" android:configChanges="mcc|mnc|locale|touchscreen|keyboard|keyboardHidden|navigation|orientation|screenLayout|uiMode|screenSize|smallestScreenSize|fontScale|layoutDirection|density" android:hardwareAccelerated="false">      <intent-filter>        <action android:name="android.intent.action.MAIN" />        <category android:name="android.intent.category.LAUNCHER" />        <category android:name="com.htc.intent.category.VRAPP" />        <category android:name="android.intent.category.LEANBACK_LAUNCHER" />      </intent-filter>      <meta-data android:name="unityplayer.UnityActivity" android:value="true" />      <meta-data android:name="unityplayer.SkipPermissionsDialog" android:value="true" />      <meta-data android:name="no_controller_pairing" android:value="true" />    </activity>    <meta-data android:name="unity.build-id" android:value="04c166df-0549-4e6e-8923-99623acdba98" />    <meta-data android:name="unity.splash-mode" android:value="0" />    <meta-data android:name="unity.splash-enable" android:value="True" />    <meta-data android:name="android.max_aspect" android:value="2.1" />  </application>  <!-- <uses-permission android:name="android.permission.CAMERA" /> -->  <!-- <uses-permission android:name="android.permission.READ_EXTERNAL_STORAGE" /> -->  <uses-permission android:name="com.htc.vr.core.server.VRDataWrite" />  <uses-permission android:name="com.htc.vr.core.server.VRDataRead" />  <uses-permission android:name="com.htc.vr.core.server.VRDataProvider" />  <uses-feature android:glEsVersion="0x00020000" />  <uses-permission android:name="android.permission.INTERNET" />  <uses-feature android:name="android.hardware.touchscreen" android:required="false" />  <uses-feature android:name="android.hardware.touchscreen.multitouch" android:required="false" />  <uses-feature android:name="android.hardware.touchscreen.multitouch.distinct" android:required="false" /></manifest>


Evidently the instruction is in there. However the app still requests pairing. I have 2 Vive Focus headsets and both request pairing so the issue is not with the hardware. Is there anything else we're missing? Have you achieved this yourself? Is there a Vive Focus specific limitation? 

I'd love to hear from you soon.

Link to comment
Share on other sites

Do you have the latest firmware update? Yes, I have it currently working with that manifest entry on any Focus I tested  with (that has the latest firmware). It's specifically useful when developing and you have set your app as the kiosk mode app - then you never have to deal with the controller (again this is use-case specific e.g. for playing 360 videos or using gaze navigation)

 

best,

Dario

 

Link to comment
Share on other sites

Below is my manifest which works (in Assets/Plugins/Android/AndroidManifest.xml - make sure there's not other ones)

 

It doesn't require Kiosk, I only mentioned it because you can boot into your app controller free if you do use kiosk mode.  When was your last firmware update?

 

AndroidManifest.xml:

 

<?xml version="1.0" encoding="utf-8"?>
<manifest xmlns:android="http://schemas.android.com/apk/res/android"
package="com.unity3d.player"
xmlns:tools="http://schemas.android.com/tools">
<application android:icon="@drawable/app_icon"
android:label="@string/app_name"
android:theme="@style/Theme.WaveVR.Loading"
android:resizeableActivity="false"
tools:replace="android:theme"> <!--You can use your theme here.-->
<activity android:name="com.htc.vr.unity.WVRUnityVRActivity"
android:label="@string/app_name"
android:enableVrMode="@string/wvr_vr_mode_component">
<intent-filter>
<action android:name="android.intent.action.MAIN" />
<category android:name="android.intent.category.LAUNCHER" />
<category android:name="com.htc.intent.category.VRAPP" />
</intent-filter>
<meta-data android:name="unityplayer.UnityActivity" android:value="true" />
<meta-data android:name="unityplayer.SkipPermissionsDialog" android:value="true" />

<meta-data android:name="no_controller_pairing" android:value="true" />

</activity>
</application>

<uses-permission android:name="android.permission.CAMERA" />
<uses-permission android:name="android.permission.READ_EXTERNAL_STORAGE" />
<uses-permission android:name="android.permission.WRITE_EXTERNAL_STORAGE" />

<uses-permission android:name="com.htc.vr.core.server.VRDataWrite"/>
<uses-permission android:name="com.htc.vr.core.server.VRDataRead"/>
<uses-permission android:name="com.htc.vr.core.server.VRDataProvider" />
</manifest>

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...