Jump to content

Vive Setup software not running


Recommended Posts

I have recently downloaded the ViveSetup.exe file from https://www.vive.com/eu/setup/vive/. When I try to run it as administrator it firstly says "Vive Checking version" then it gives the error: "Download failed, please check the network connection and try again".


I have disabled the firewall and tried other web browsers to download. I also tried downloading the file on another network and transferred the file to my computer on which I intend to run vive, but I get the same error. 


The file is 2.7 Mb and downloads instantly but it stalls at the very end of the download for 4-5 seconds although there is 0 byte left. This here already looks problematic.  


Please help me get through this very first step, I am yet to use the VR on my new computer..


Link to comment
Share on other sites


 may be able to help you with this.

Just so you know, you don't need to install that software to use your Vive. You only need SteamVR. You can skip that step for now if it's not working for you and get back to it later once you've had a chance to enjoy your new purchase for a while.

Thank you,

-John C

Link to comment
Share on other sites

I've started a support ticket with the email address associated with your forum accounts so I can directly connect you with a team member that's able to help you debug the issue you're encountering. As synthesis said, you're still able to use the HMD via Steam/SteamVR without the Vive installer completing. 

Link to comment
Share on other sites

  • 2 years later...

I am having the exact same issue. the head set was fine and then after not using it for a couple of days it just decided not to work. so I tried to make a completely new set up and Now its giving me this exact same error. I t never did this the first time I set it up. Why now?


Link to comment
Share on other sites

  • 6 months later...

I am installing a VIVE Eye Pro on a corporate network behind their firewall.  I have downloaded ViveSetup.exe and run, but it just says checking version and fails saying Download failed check network connection.  I am assuming it is having some ports blocked by the firewall.  

Can you tell me specifically what ports I need to have opened by IT for the VIVE setup, wireless, and VIVEport software?





Link to comment
Share on other sites

  • 6 months later...

Hi Everyone,

Here's how I fixed this issue -

1). Clicked on Start
2). Typed RUN (then Enter)
3). Typed %TEMP% (into the Run Box)
4). Clicked on OK

Note: The TEMP folder opens in Explorer

5). Select all files (in the TEMP folder)
6). Delete all files (in the TEMP folder)
7). Rebooted

I was then able to install the software again.

I hope that this helps.

Kind Regards,


Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...