Jump to content

Snapdragon Profiler


JLeBlanc
 Share

Recommended Posts

Hi,

I've followed the documentation on the Snapdragon profiler's website and can't seem to get it to work with an Unreal Project in the Focus.

I've downloaded the wave_3.1.6_unreal_1(Beta).zip example project (UE 4.21).
I packaged that example project, pushed it to my Focus.

I've followed all the steps in the Snapdragon Docs found here: https://developer.qualcomm.com/software/snapdragon-profiler/tools

I start the Focus, connect to the device in the Snapdragon Profiler.
Now when I try to start the example Unreal Wave app I get a black screen and hear the speaker keep clicking over and over again like it's stuck in a loop trying to load the app.

What am I missing?

Thanks,
Jesse

 

@Cotta

Link to comment
Share on other sites

Hi @JLeBlanc

Sorry we don't have much experience debugging Snapdragon Profiler problems. We did a quick test on a simple Unreal app and it does work here. Just that the Profiler shows no response for about one minute after selecting the app to launch. Maybe you can try clarify this problem by contacting Qualcomm.

And actually Wave SDK also provides a Profiler for Unreal. You may refer to this page: https://hub.vive.com/storage/docs/en-us/UnrealPlugin/UnrealProfiler.html

We'd suggest you can have a try, if there is no other reason you must use Snapdragon Profiler.

Link to comment
Share on other sites

On 1/17/2020 at 5:22 PM, JLeBlanc said:

Hi,

I've followed the documentation on the Snapdragon profiler's website and can't seem to get it to work with an Unreal Project in the Focus.

I've downloaded the wave_3.1.6_unreal_1(Beta).zip example project (UE 4.21).
I packaged that example project, pushed it to my Focus.

I've followed all the steps in the Snapdragon Docs found here: https://developer.qualcomm.com/software/snapdragon-profiler/tools

I start the Focus, connect to the device in the Snapdragon Profiler.
Now when I try to start the example Unreal Wave app I get a black screen and hear the speaker keep clicking over and over again like it's stuck in a loop trying to load the app.

What am I missing?

Thanks,
Jesse

 

@Cotta @Tony PH Lin @reneeclchen

Thanks Cotta,

Did you mean you had an additional profiler aside from Unreal's built in one, or you just have instructions on how to use Unreal's profiler?

If I find a fix for my snapdragon profiler issue I will come back with my solution.

Thanks!

 

@Cotta

Link to comment
Share on other sites

  • 2 weeks later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...