Jump to content

Workstation fail to communicate with Vive link box through Mini displayport. Issuing an HDCP error


Recommended Posts

Hello everyone,

Just came here to share an issue that I've been having with the  Vive Pro Eye and a Dell Precision 7550 workstation that I got from work. 

System Specs

Dell Precision 7550

CPU: Intel Core i7 10850H @2.7GHz

GPU: Nvidia Quadro RTX 5000 with Max-Q Design

RAM: 2x16GB ddr4 @2993MHz

VR Set: HTC Vive Pro Eye

The Issue

I'm trying to set up a VR station with this hardware, so instead of using the normal Mini DP(displayport) cable to DP that comes with the Vive, I bought a Mini DP to Mini DP cable to use it with the Precision (the laptop has only one mini DP port, one HDMI  and 2 USB-C 3.1ports to be used with docking stations).

Interesting enough, I can set everything up to make the device work, but it seems that I'm getting an HDCP error when the port is trying to communicate the video with the Vive Base Station, resulting in no display in the headset whatsoever.

I've already tried a bunch of solutions, I'll list them here:

  • Clean install of both steam, Vive and Steam VR, no result
  • Switched between Direct and Extended mode in Steam VR, no result
  • Enabled Discrete graphics controller in BIOS, no result as well
  • Updated everything that should be updated (Windows, video Drivers, BIOS, Dell updates) 
  • Clean Display driver uninstall (with DDU), no result
  • Tried old driver versions as well, no luck

I can confirm that the Vive is working as intended, as I tested it in another VR Capable desktop (with an RTX 2070), but this time with the original displayport cable. I've also tested it with a Dell docking station through USB C 3.1, it works, but with a little bit of display delay, I guess that's because of the USB bandwidth.

I can also confirm that the Precision mini DP is working, as a tested it with a DP capable monitor.

A colleague of mine also got to test the machine with his own Vive, with a different Mini DP cable, and got the same issue, that's what got to my concern to open this discussion.

Research and Speculation

After doing some research, I found out that some users were having this trouble with an RTX 2080 in some Alienware area-51m models, and their solution was to revert to an old driver version, and it was all good, at least for them to use it. 

Thing is that, with this one that I've got, is uses an Quadro RTX 5000, which is a relatively new board, and does not use the same drivers as the Geforce RTX models, so I'm kind of stuck on this field. The theories that I have are narrowed down to 2 at the moment:

  • 2 people, with 2 different VR devices, 2 different brand new Mini DP cables, aren't able to run, so the only explanation would be the cables. Highly doubt that both of these cables are poor quality, but it's a possibility.
  • There's something messed up with NVidia drivers for this model in specific that doesn't recognize VR devices through the external displayport

I'm opening this thread to see if someone has already seen this issue, or if they have any tips or suggestions to debug this even further. I've already opened an issue with Dell as well, but got no answer from them as it is now. If you need further info, please ask away!

Thanks in advance

Luiz Henrique Pereira

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...