Jump to content

Overlay keyboard not working for Quest


Recommended Posts

I have ported my Vive project to the Quest and am still very happy about using the Vive Input utility. But I'm having a weird and frustrating problem.

On my ported project the overlay keyboard will not come up when I click on an InputField. I have another Quest project that I use for testing and there it works fine. I also ran the UGUI sample scene in the ported project and there I have the same problem. Everything else works (button, slider, toggle, scrollview, dropdown), only the inputfield does not work.

I can see that there is a difference in the VIU version. The project that works has VIU, the project where it does not work has VIU, so a more recent version. I tried updating to the lastest version (1.14.1) but that also did not solve the problem.

I tried copying the HTC.UnityPlugin folder from the working project to the not-working project, but that gave compile errors, so I reverted that.

In the Android LogCat window I do see the debug message saying "SteamVR plugin not found, install it to enable overlay keyboard", but I get that in both projects, so it is not causing the problem (and it's actually an incorrect message, as SteamVR plugin is not really required).

So I hope you can help, maybe something was updated between version 1.12.2 and 1.13 that broke the overlay keyboard? Or it is something in my project and you can point me in the right direction 🙂 @chengnay


Link to comment
Share on other sites

@chengnay Thanks for your reaction. Yes, the UGUI sample works fine in VIU V1.12.2.

And I realised this morning that I did not check one component, the Oculus Integration package. And that was the cause. I finally found a post to check the Oculus Integration package version (https://forums.oculusvr.com/t5/Unity-VR-Development/Unity-Oculus-Integration-version-number/td-p/864283) and with that I found the difference.

My test project that has VIU 1.12.2 has wrapper version 1.52.0, which is older than the versions mentioned on the archive page in the post, so earlier than 27.0.
The ported project that has VIU 1.13.4 has wrapper version 1.64.0, so Oculus Integration version 32.0

When I copied the Oculus folder from the working project to the not-working project the problem was solved.

To complete my troubleshooting I upgraded (a copy of)  the test project to the latest Oculus Integration (35) and the latest VIU (1.14.1). And there the problem appeared again. The InputField in both the UGUI scene and in my own scene do not trigger the overlay keybaord. The rest of the UGUI scene works fine.

I am using Quest 1, Unity 2019.4.18f1 with the built-in SDK/NDK and gradle, building for minimal Android 6, target highest installed.

I hope this gives you some directions for fixing the problem. For now I'm sticking with the old Oculus Integration package as that works. 🙂

Link to comment
Share on other sites

  • 2 weeks later...

@jboss After comparing between your project and mine, I can confirm that VIU is not the root cause to this issue.

I did upgrade your project to latest VIU v1.14.1 and everything works fine.

After comparing your Oculus plugin with mine, I found below difference and it is the root cause to the virtual keyboard issue.


Let me know if you still got other issue, thanks!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...