Jump to content

Cosmos - Can not connect to DisplayPort at setup + Headset Not Detected Error


Recommended Posts


I'm having a set up issue with my Cosmos w/ link and 1660 Ti with single monitor.  During the setup I get stopped at the detection phase. 

Link - Green light comes on, red light comes on headset, all cables appear secure.  I've tried taking everything out and replacing and powering off/on. Checked for system updates, updated VIVE console and rebooted.

USB - Setup eventually confirms the USB, though suggests a 3.0 connection.  I checked the Device for system and it does show USB 3.0 available.  I've tried multiple USB ports built into motherboard and top-of-case USB by headphones jack.  Windows does make the "connected/disconnected" noise if I turn the link on/off. 

DisplayPort - Setup will spin for awhile then do a popup instructions (showing not to plug into the motherboard displayport, instead use graphics card port.)  I've tried other slots on graphics card.  Never connects or confirms.

VIVE Console - Error 001 : Headset is not connected.


  • Like 1
Link to comment
Share on other sites

  • 10 months later...
  • 3 months later...
  • 2 weeks later...

I have the same issue, how did you fix it?

I am running a RTX 2070 which is recognising the display port but the USB detection tells me I need a usb3.0 or higher which I have, I am running other usb3.0 peripherals. I have tried every usb port on the PC with the same result, I have been through the supports pages recommendations and I have even uninstalled after MoBo driver and windows updates then re-installed. No success but lots of frustration.


Edited by Daniel Moloney
Link to comment
Share on other sites

what fixed it for me is buying a new power plug I found that I had been pushing the end into the link box too hard which caused the same issue I found just lightly plugging in until you hear a click and had no issues since. you can buy a new plug on the HTC website.

Edited by Benzo
spelling mistake
Link to comment
Share on other sites

I have the same problem with my vive cosmos. USB connect then disconnect in a loop. In the setup guide display port connected then disconnect. USB give an error plug to usb 3.0 but it is connected to usb 3.0. after I reconnect the usb the status changed to detecting usb connection then the setup guide close. The status in vive console is 001. Try all the usb port. Same problem.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...